Page MenuHomePhabricator

Manage ORES preferences on Watchlist (and Contributions)
Closed, ResolvedPublic

Description

T159763 describes how making ORES default (instead of a beta) and releasing of the New Filters beta affects ORES functions on RC Page and RC Page preferences. This ticket describes all the changes that need to happen relating to Watchlist (and Contributions) and the Watchlist Preferences tab.

  • Highlight probably damaging edits on Watchlist and Contributions (using ORES)
    • Add this new Preference to the Watchlist prefs in the "Revision Scoring" section. It turns on classic ORES shading on Watchlist and Contributions.
    • For existing ORES users, this will be turned ON by default when they are migrated.
    • For everyone else, this preference will be OFF by default.
    • (Classic ORES shading will NOT be available on RC Page under any scenario)
  • Ores Sensitivity controls
    • These controls currently exist on Recent changes. They will be relocated to the Revision Scoring section of Watchlist.
    • The controls will now control Watchlist, Contributions AND Recent Changes
    • On Watchlist and Contribs they will work more or less as now. On RC Page they will have a somewhat diminished effect (as described in T159763)
    • However, the wording and threshold levels of the Sensitivity controls will be changed to conform with ERI, as described in subtask T160575
  • "Hide probably good edits from Watchlist"
    • This preference remains where it is, on Watchlist in Revision Scoring.
    • As before, it effects Watchlist and Contributions.
    • To reflect the above, the option should be reworded as follows: Hide probably good edits from Watchlist and Contributions superseded by T162831
    • This option works independently of "Highlight probably damaging edits" (above). That is, users to not need to select that to get this.
    • The ORES Sensitivity controls will continue to determine what edits count as "probably good" and do or don't get hidden. However, the thresholds for that will be conformed to the ERI ORES levels (as in T160575)
  • "r" flags for "needs review"
    • These are the little "r" flags that ORES shows for edits with damaging scores above a certain threshold.
    • Because ORES is on by default, the "r" will now display for everyone on Watchlist and Contribs pages (instead of being dependent on users selecting the ORES beta).
    • The ORES Sensitivity controls will continue to determine what edits do or don't get the "r". However, the thresholds for that will be conformed to the ERI ORES levels (as in T160575)

Related Objects

Event Timeline

@SBisson this is assigned to you because it was created as a subtask of T159763. If you want to put unassign yourself, go ahead.

Change 342964 had a related patch set uploaded (by Catrope):
[mediawiki/extensions/ORES] Follow-ups to 980fb74d7: move classic highlights to watchlist

https://gerrit.wikimedia.org/r/342964

@SBisson, the spec for this page has changed considerably. Please review the Description carefully. (The good news is that it sounds like many of the things I think of as "changes" are just descriptions of the way Roan already arranged things.)

Change 342964 merged by jenkins-bot:
[mediawiki/extensions/ORES] Follow-ups to 980fb74d7: move classic highlights to watchlist in 'on' mode

https://gerrit.wikimedia.org/r/342964

Change 343083 had a related patch set uploaded (by Sbisson):
[mediawiki/extensions/ORES] Reword highlight preference

https://gerrit.wikimedia.org/r/343083

Change 343083 merged by jenkins-bot:
[mediawiki/extensions/ORES] Reword highlight preference

https://gerrit.wikimedia.org/r/343083

To reflect the above, the option should be reworded as follows: Hide probably good edits from Watchlist and Contributions (and Recent Changes for users who have not selected the New Filters for Edit Review beta).

Having the ORES extension word its user preference differently based on whether the current user has enabled the ERI beta feature is quite problematic in terms of coupling between Core, ORES, and WikimediaMessages.

Two alternatives would be to reword it in more general terms so it can apply to RC or not or leave it as it is and respect it in the new interface (adding "Maybe damaging" by default).

I think the description also misunderstands the "Hide probably good edits" preference. There are two of them, an RC one and a watchlist one.

Moving this to QA because it's 90% done, and what isn't done is either covered by T160575 or misunderstood by the current description. This task also seems to be almost entirely a duplicate of T159763

Change 343343 had a related patch set uploaded (by Catrope):
[mediawiki/extensions/ORES] Hide oresRCHideNonDamaging pref if rcenhancedfilters is enabled

https://gerrit.wikimedia.org/r/343343

jmatazzoni added a comment.EditedMar 17 2017, 9:58 PM

@SBisson and @Etonkovidova, please note that I just changed the Description here to reflect changes made in T159763. The changes here relate to the fact that the "Hide Probably Good Edits from Watchlist" option will NOT control that function on RC page, which will continue to have its own "Hide Probably Good..." option. (The "Hide Probably Good" section is the only one I changed here.)

Change 343343 merged by jenkins-bot:
[mediawiki/extensions/ORES] Hide oresRCHideNonDamaging pref if rcenhancedfilters is enabled

https://gerrit.wikimedia.org/r/343343

I ran the final check on ptwiki and plwiki and, along with checked T159763: Enable parts of ORES extension by default and manage impacts on the RC Page and the RC page Preferences tab , all specs seem to be in place.

Note: Having the option "Highlight probably damaging edits on Watchlist and Contributions (using ORES)" as Off by default, seems a little bit of a deviation, sort of, from the previous behavior when ORES and highlighting were inseparable. The option is not easily discoverable. But it's a side note.

QA Recommendation: Resolve

@SBisson, One thing here is missing. I apparently thought the option below was located in the Revision scoring area, but I guess it was not. Please move it there:

"Hide probably good edits from Watchlist"-- please move this option to the Revision Scoring section, under the "Highlight probably damaging edits..." option.

Change 345317 had a related patch set uploaded (by Sbisson):
[mediawiki/extensions/ORES@master] Move oresWatchlistHideNonDamaging to watchlist/ores pref section

https://gerrit.wikimedia.org/r/345317

@SBisson, One thing here is missing. I apparently thought the option below was located in the Revision scoring area, but I guess it was not. Please move it there:
"Hide probably good edits from Watchlist"-- please move this option to the Revision Scoring section, under the "Highlight probably damaging edits..." option.

Done in https://gerrit.wikimedia.org/r/345317, pending review and merge.

Change 345317 merged by jenkins-bot:
[mediawiki/extensions/ORES@master] Move oresWatchlistHideNonDamaging to watchlist/ores pref section

https://gerrit.wikimedia.org/r/345317

@SBisson Tested on cawiki-betalabs which has default ORES and 'New filters for edit review' as a beta-feature

A user with not-enabled 'New filters for edit review' has

  • Preferences-Recent changes 'Show only edits that may have problems (and hide probably good edits)'
  • Preferences-Watchlist has three options in 'Revision scoring': 'Sensitivity ORES', 'Highlight probably damaging edits on Watchlist and Contributions (using ORES)', and ' Hide probably good edits from Watchlist'

A user with enabled 'New filters for edit review' has

  • no ORES related options in Preferences-Recent changes
  • Preferences-Watchlist has three options in 'Revision scoring': 'Sensitivity ORES', 'Highlight probably damaging edits on Watchlist and Contributions (using ORES)', and ' Hide probably good edits from Watchlist'

There is no reference to 'Contributions' in Preferences-Watchlist option ' Hide probably good edits from Watchlist', but according to the specs, it should be changed to the following:

the option should be reworded as follows: Hide probably good edits from Watchlist and Contributions

Note: due to the specific setup, enwiki-betalabs has both beta features are present: 'New filters for edit review' and 'ORES', and the options for 'Watchlist' are not displayed as they should be.

If a user enables both beta features

  • Preferences-Watchlist has only the following setting: 'Show only edits that may have problems (and hide probably good edits)' in 'Revision scoring' section
  • Preferences-Recent changes still has: 'ORES sensitivity' under 'Revision scoring'

the option should be reworded as follows: Hide probably good edits from Watchlist and Contributions

I remember rewording those preferences to the form: Show only edits that may have problems (and hide probably good edits) but I can't find in which ticket that was specified.

Note: due to the specific setup, enwiki-betalabs has both beta features are present: 'New filters for edit review' and 'ORES', and the options for 'Watchlist' are not displayed as they should be.
If a user enables both beta features

  • Preferences-Watchlist has only the following setting: 'Show only edits that may have problems (and hide probably good edits)' in 'Revision scoring' section
  • Preferences-Recent changes still has: 'ORES sensitivity' under 'Revision scoring'

I don't know what it should do in this case, if it's even a valid setup. Our plan is to turn ORES 'on' on wikis where we enable the RC Filters beta feature.

@jmatazzoni What do you think of the two points above?

If a user enables both beta features

  • Preferences-Watchlist has only the following setting: 'Show only edits that may have problems (and hide probably good edits)' in 'Revision scoring' section
  • Preferences-Recent changes still has: 'ORES sensitivity' under 'Revision scoring'

I don't know what it should do in this case, if it's even a valid setup. Our plan is to turn ORES 'on' on wikis where we enable the RC Filters beta feature.

enwiki in beta has an invalid setup currently, because RCFilters is available but ORES is in 'beta' mode rather than 'on'.

@jmatazzoni Please confirm that we are changing the label to reflect the fact that Contributions are being affected by thesetting on the Watchlist.

the option should be reworded as follows: Hide probably good edits from Watchlist and Contributions

I remember rewording those preferences to the form: Show only edits that may have problems (and hide probably good edits) but I can't find in which ticket that was specified.

I was thinking again on it.
If someone reviews the edit and approves it, it is gone.
What about the case when others don't trust the revisions done by some users? In this case, we need to keep the "r" visible for everyone. Maybe have a choice in preferences, like:
( ) Don't show the predictions
( ) Show predictions for edits that haven't been reviewed
( ) Always show the predictions

@jmatazzoni I am moving the ticket to 'Product Review' although the specs described below have not been implemented. Please review and let me know if the specs need to be implemented as part of this ticket or a new ticket should be created.
QA Recommendation: Product should weigh in

Hide probably good edits from Watchlist"
This preference remains where it is, on Watchlist in Revision Scoring.
As before, it effects Watchlist and Contributions.
To reflect the above, the option should be reworded as follows: Hide probably good edits from Watchlist and Contributions

Two points from above have not been implemented:
(1)

As before, it effects Watchlist and Contributions.

Selecting Preference-Watchlist 'Show only edits that may have problems (and hide probably good edits)' does not affect Contributions - 'Hide probably good edits'. The Contribution option 'Hide probably good edits' is independent.

(2)

To reflect the above, the option should be reworded as follows: Hide probably good edits from Watchlist and Contributions

'Contirbutions' is not mentioned in 'Show only edits that may have problems (and hide probably good edits)'
In betalabs

ptwiki Preferences-watchlist options look like the following:

Quiddity removed a subscriber: Quiddity.Jun 30 2017, 9:23 PM
jmatazzoni closed this task as Resolved.Nov 21 2017, 9:19 PM