Page MenuHomePhabricator

$wgMaxUploadSize being an array causes an error in Page Forms
Closed, ResolvedPublic

Description

Copied from https://www.mediawiki.org/wiki/Extension_talk:Page_Forms#PF_UploadForm.php_introduces_fatal_error_when_.24wgMaxUploadSize_is_an_array:

The document of $wgMaxUploadSize (https://www.mediawiki.org/wiki/Manual:$wgMaxUploadSize) suggests it can be set to an array, thus offering the ability to vary url max upload size from direct max upload size.
In the page form upload window, however, if wgMaxUplaodSize was an array, a fatal error would be thrown by

 wfMessage( 'upload-maxfilesize',
        $this->getLanguage()->formatSize( $wgMaxUploadSize )
)->parse() . ' ' . wfMessage( 'upload_source_url' )->escaped(),

since the message handler couldn't deal with the array parameter. This can be easily reproduced in Page Form master branch as of March 14th, 2017.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 16 2017, 8:08 PM
Fz-29 claimed this task.Mar 16 2017, 9:20 PM

Change 343457 had a related patch set uploaded (by Fz-29):
[mediawiki/extensions/PageForms] Issue Solved - $wgMaxUploadSize being an array causes an error in Page Forms

https://gerrit.wikimedia.org/r/343457

Change 343534 had a related patch set uploaded (by Fz-29):
[mediawiki/extensions/PageForms] Issue Solved - $wgMaxUploadSize being an array causes an error in Page Forms

https://gerrit.wikimedia.org/r/343534

Change 343534 merged by jenkins-bot:
[mediawiki/extensions/PageForms] Issue Solved - $wgMaxUploadSize being an array causes an error in Page Forms

https://gerrit.wikimedia.org/r/343534

Yaron_Koren closed this task as Resolved.Mar 20 2017, 2:39 AM

Fixed, I think!

Change 343457 abandoned by Fz-29:
Issue Solved - $wgMaxUploadSize being an array causes an error in Page Forms

https://gerrit.wikimedia.org/r/343457