Page MenuHomePhabricator

Upload php7.1 to apt.wm.org
Closed, DeclinedPublic

Description

Reason why i would like php 7.1 uploaded to apt.wm.org is because it's performance is much better. I would like to experiment with php 7.1 more with phabricator. When i have finished that testing i would like to eventually upgrade the phabricator server (prod) to 7.1.

Reason why 7.1 and not 7.0 is because 7.0 removed a feature phabricator was using and was only recently added back in 7.1 + it always is better to go with a .1 release then a .0 release.

Also stretch is using 7.0 so thats why we need it also uploaded to apt.wm.org.

Please.

Event Timeline

Paladox created this task.Mar 16 2017, 10:29 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 16 2017, 10:29 PM
Paladox updated the task description. (Show Details)Mar 16 2017, 10:30 PM
MoritzMuehlenhoff closed this task as Declined.Mar 17 2017, 10:43 AM

We won't provide PHP 7.1 in the foreseeable future. Providing a package like PHP on apt.wikimedia.org is not a one time effort, but requires continuous maintenance and is not done lightly. The forthcoming Debian release will have only 7.0 as well, you should rather apply a backwards compatibility fix to Phabricator.

Paladox added a comment.EditedMar 17 2017, 10:50 AM

@MoritzMuehlenhoff We won't be able to apply backwards compatible fix for phabricator. Since the daemons uses a php 7.1 feature and a 5.* feature. It won't be able to support php 7.0. Upstream have already decided that too. Stuff like importing git repo to uploading patches through differential will not work as the daemons won't be able to run under php 7.0 due to the missing feature. There is no alternative feature in php 7.0 we can use.

demon removed a subscriber: demon.Mar 17 2017, 11:07 PM
mmodell added a comment.EditedFeb 12 2018, 11:56 PM

@MoritzMuehlenhoff: There is at least one 3rd party PHP 7.1 package available [ 1 ]. Could we not use their source packages to build our own binaries? I realize it is indeed a large amount of maintenance, however, it seems preferable to being stuck on a buggy and obsolete version of PHP for the next couple of years.

Don't mind me, but it seems like Debian does have packages for php7.1 and php7.2, albeit in newer release channels, but perhaps we prefer backporting those over using a different third party? https://packages.debian.org/buster/php, https://packages.debian.org/buster/php7.1. (Buster is currently in testing still, though.)

I think those packages are the same - sury.org is owned by the debian maintainer for php - so those are semi-official backports, as far as I can tell.

Confirmed: all of the news entries on https://tracker.debian.org/pkg/php7.1 are by Ondřej Surý.

I've tested buster php 7.1 packages on stretch and they work see https://phab-stretch.wmflabs.org

Maybe we can either pin php* and the apache2 php package to buster or backport buster packages into stretch-wikimedia?