Page MenuHomePhabricator

[Regression] Watchlist filters set in Preferences can't be disabled on Watchlist
Closed, ResolvedPublic

Description

Steps to reproduce:

  1. Go to Spezial:Preferences#mw-prefsection-watchlist and enable a filter, e.g. check "Hide minor edits from the watchlist"
  2. Go to Special:Watchlist, note that the filter is checked by default as expected.
  3. Uncheck the filter (and, depending on your settings, click the "Show" button to apply the change).

Expected: The filter is (temporarily) unchecked, overriding your preferences.
Actual: The filter is checked, always enforcing the settings you made in your preferences.

Event Timeline

Schnark created this task.Mar 17 2017, 9:09 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 17 2017, 9:09 AM
Schnark added subscribers: Catrope, Mattflaschen-WMF.

@Mattflaschen-WMF, @Catrope: Given that rMWaa063f4c5a19: Back-end of new RecentChanges page, refactoring is a rather large change, that was deployed recently and touches the code that is probably responsible for this bug, can you please double-check the change?

Catrope claimed this task.Mar 17 2017, 5:39 PM

I have to go run an errand now, but when I get back (in 45-60 mins) I'll look into this.

We found the cause, and Matt came up with a strategy for fixing it that I like.

Change 343407 had a related patch set uploaded (by Mattflaschen):
[mediawiki/core] Watchlist: Fix unchecked boxes on the form overriding checked prefs

https://gerrit.wikimedia.org/r/343407

@Etonkovidova See the commit message for expected behavior.

Change 343407 merged by jenkins-bot:
[mediawiki/core] Watchlist: Fix form and preference overriding

https://gerrit.wikimedia.org/r/343407

Change 343433 had a related patch set uploaded (by Catrope; owner: Mattflaschen):
[mediawiki/core] Watchlist: Fix form and preference overriding

https://gerrit.wikimedia.org/r/343433

The fix for this bug is scheduled for deployment on Monday March 20 at 13:00-14:00 UTC.

Change 343433 merged by jenkins-bot:
[mediawiki/core] Watchlist: Fix form and preference overriding

https://gerrit.wikimedia.org/r/343433

Mentioned in SAL (#wikimedia-operations) [2017-03-20T13:34:04Z] <zfilipin@tin> Synchronized php-1.29.0-wmf.16/includes/specials/SpecialWatchlist.php: SWAT: [[gerrit:343433|Watchlist: Fix form and preference overriding (T160734)]] (duration: 01m 01s)

Mentioned in SAL (#wikimedia-operations) [2017-03-20T13:35:09Z] <zfilipin@tin> Synchronized php-1.29.0-wmf.16/tests/phpunit/includes/specials/SpecialWatchlistTest.php: SWAT: [[gerrit:343433|Watchlist: Fix form and preference overriding (T160734)]] (duration: 00m 48s)

This is deployed. Sorry for the inconvenience.

Checking/unchecking boxes for on Watchlist page overrides Watchlist preferences. Checked in testwiki (after beta feature 'New filters for edit review' was deployed), and in wmf.16.

Also, checked Contributions page. Selecting/deselecting options function as expected.

QA Recommendation: Resolve

jmatazzoni closed this task as Resolved.Mar 22 2017, 9:09 PM