Page MenuHomePhabricator

Visual diff represents changes since entering VE, so switching from wikitext means diff isn't complete (can be null) which is confusing
Closed, ResolvedPublic8 Estimated Story Points

Description

Steps to reproduce:

  1. Open a page for editing in wikitext mode (reproducible both with OWE and NWE).
  2. Change something.
  3. Switch to VE.
  4. Click "Save", "Review changes", note that your changes are shown in the wikitext diff.
  5. Switch to visual diff.

Expected: Your changes are shown (or the button is grayed out if the diff can't get the original document from somewhere).
Actual: The visual diff claims you didn't change anything.

Event Timeline

Schnark created this task.Mar 17 2017, 10:56 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 17 2017, 10:56 AM
Jdforrester-WMF renamed this task from No visual diff shown after switching from wikitext to Visual diff represents changes since entering VE, so switching from wikitext means diff isn't complete (can be null) which is confusing.Mar 20 2017, 7:35 PM
Jdforrester-WMF triaged this task as Medium priority.
Jdforrester-WMF set the point value for this task to 8.Mar 24 2017, 1:13 AM

Change 347220 had a related patch set uploaded (by Esanders):
[mediawiki/extensions/VisualEditor@master] VisualDiff: Fetch original doc from Parsoid if fromEditedState

https://gerrit.wikimedia.org/r/347220

Change 347220 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] VisualDiff: Fetch original doc from Parsoid if fromEditedState

https://gerrit.wikimedia.org/r/347220

Jdforrester-WMF closed this task as Resolved.Apr 10 2017, 5:20 PM
Jdforrester-WMF assigned this task to Esanders.
Jdforrester-WMF removed a project: Patch-For-Review.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptApr 10 2017, 5:20 PM