Page MenuHomePhabricator

History tools not updating when user starts editing (ve-mw only)
Closed, ResolvedPublic1 Story Points

Description

  1. start typing
  2. observe the undo button is still disabled

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 20 2017, 12:51 PM
Esanders triaged this task as Unbreak Now! priority.Mar 20 2017, 12:53 PM
Restricted Application added subscribers: Jay8g, TerraCodes. · View Herald TranscriptMar 20 2017, 12:53 PM

Looks like the history tool is connected to the temporary loading surface, and not re-connected to the real surface when it is created.

Change 343634 had a related patch set uploaded (by Esanders):
[VisualEditor/VisualEditor] Fire a surface change event from the toolbar so tools can rebind

https://gerrit.wikimedia.org/r/343634

This also manifests itself in the standalone demo if you add another surface and switch to it.

Change 343634 merged by jenkins-bot:
[VisualEditor/VisualEditor] Fire a surface change event from the toolbar so tools can rebind

https://gerrit.wikimedia.org/r/343634

Change 343662 had a related patch set uploaded (by Jforrester):
[mediawiki/extensions/VisualEditor] Update VE core submodule to master (f294778e6)

https://gerrit.wikimedia.org/r/343662

Jdforrester-WMF closed this task as Resolved.Mar 20 2017, 3:43 PM
Jdforrester-WMF assigned this task to Esanders.
Jdforrester-WMF set the point value for this task to 1.
Jdforrester-WMF moved this task from To Triage to TR0: Interrupt on the VisualEditor board.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMar 20 2017, 3:43 PM

Change 343662 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor] Update VE core submodule to master (f294778e6)

https://gerrit.wikimedia.org/r/343662