Page MenuHomePhabricator

Requesting access to reseachers, analytics-wmde, analytics-users for GoranSMilovanovic
Closed, ResolvedPublic

Description

Username: GoranSMilovanovic
Full name: Goran S. Milovanović
Org: WMDE
Preferred shell user name: goransm

Data Need:
Data Analyst, WMDE: various Data Science related tasks (e.g. access to datasets, data modeling, and similar)

Public Key:
ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABAQC6jc1W0mqEnurNhtYXF9YQpCX3H4h1pQA9jgZXKGTPUczQJ2rRVZKWXxuPfbg0OwZFzVKhTtSi0HO2v0Dy4gOtrDMpxfX51HnsB/Sm+ifngkj5AgSiAylT7P4PNm7F804m7iJF277DDx/+R9JAL59NT0C9nTZ6oKghL37TQr/PdHBRhjZjRzMOjuplwoFh+I9ZtLGQJpqTENKWqqYwxwMdjog/fRf3+tkvB7kxwmZHRiVPBl8BS64JkNmKXX+xQCtR0YMYH8HkfE4GarSnDXSqmhwS6Zx8TY7oVPy0d5H8cZaA2RyoYWzEH4K2rbvllLoZCnto5Elb6ic0BVP7P8Fn goran@goranNET

requirements to be met for access

  • - L3 document signed - done on Tue, Mar 21, 08:56
  • - wikitech username is same as preferred shell name, uid 16664, and public ssh key provided
  • - WMF Legal team must comment or email operations to confirm an NDA is on file with legal. (This is required for ALL shell requests.)
  • - specific access groups need to be provided before this can be reviewed (what servers do you need access to?)
  • - 3 business day wait (this cannot start until user lists what resources they require)
  • - @GoranSMilovanovic to provide personal email address to tie to shell account, this will be in a public repo. -> Now @wikimedia.de address.

Event Timeline

Restricted Application added a project: Operations. · View Herald TranscriptMar 21 2017, 9:14 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

@GoranSMilovanovic RESOURCE and USER[S] are placeholders to be replaced by real data

GoranSMilovanovic renamed this task from Requesting access to RESOURCE for USER[S] to Requesting access to RESOURCE for GoranSMilovanovic.Mar 21 2017, 10:29 AM

@Dereckson Sorry, still working on it... figuring out with @Addshore what RESOURCE[S} will I need...

GoranSMilovanovic renamed this task from Requesting access to RESOURCE for GoranSMilovanovic to Requesting access to reseachers, analytics-wmde, analytics-users for GoranSMilovanovic.Mar 21 2017, 11:34 AM

@Dereckson Done. Let me know if the ticket is Ok now, please. Thanks.

Dereckson added a comment.EditedMar 21 2017, 11:38 AM

@GoranSMilovanovic You need to follow https://wikitech.wikimedia.org/wiki/Production_shell_access#Requesting_access, so SSH and request information look fine.

Did you sign L3 too? If so, you're fine and we're waiting for for approvals (a Phabricator administrator will confirm you signed it).

@Dereckson Yes I have signed L3 from my Wikitech account.

Hi Goran,
your access needs an NDA. What's your @wikimedia.de email address (I couldn't find you on https://www.wikimedia.de/wiki/Mitarbeitende yet), I'll arrange this with the WMF Legal department.

Hi Moritz,

I understand that the request needs an NDA, but I still do not have a @wikimedia.de email address; contacting my colleagues at WMDE immediately on this. Thanks.

@MoritzMuehlenhoff
our IT is still working on getting an @wikimedia.de address for @GoranSMilovanovic but it will still take some time. I can confirm that @GoranSMilovanovic works as a contractor for WMDE as I (in my role as Engineering Manager) am the responsible contact for him at WMDE. If this speeds up processes, this would be great! Also, if needed, I think @Abraham can confirm this too as the head of software engineering.
Thanks!

If that takes a while to setup, we can also use an interim address for the account; @GoranSMilovanovic can you please provide a different email address where to contact you in case of emergencies etc? (Note that this email address will end up in a public puppet git repository)

@MoritzMuehlenhoff Please use goran.s.milovanovic@gmail.com for emergency cases anytime, and for any related purposes until I get an @wikimedia.de address. Thanks.

I've sent a mail to the WMF Legal department and added you to CC. When the NDA is on file, we can proceed with the access request.

MoritzMuehlenhoff removed GoranSMilovanovic as the assignee of this task.Mar 23 2017, 1:39 PM

Also, removing you as the assignee, the actual change will be handled by someone from TechOps :-)

RobH updated the task description. (Show Details)Mar 23 2017, 9:06 PM
RobH added a subscriber: RobH.

I've updated the task description with the checklist steps.

We need a couple of things from @GoranSMilovanovic still:

  • - specific access groups need to be provided before this can be reviewed (what servers do you need access to?)
  • - @GoranSMilovanovic to provide personal email address to tie to shell account, this will be in a public repo.

@RobH Groups: (1) reseachers, (2) analytics-wmde, (3) analytics-users; personal e-mail: goran.s.milovanovic@gmail.com
Comment: March 24, 2017, 1:23 CET: NDA signed.

RobH added a comment.Mar 24 2017, 3:38 PM

Thanks! Please note we still have to have legal sign off on this task. (We unfortunately cannot accept simple user confirmation of NDA, but now require legal review.)

Once we have that, everything else is set for authorizations!

RobH triaged this task as Normal priority.Mar 24 2017, 3:38 PM

Change 344735 had a related patch set uploaded (by Dzahn):
[operations/puppet@production] admins: create shell account for Goran S. Milovanovic

https://gerrit.wikimedia.org/r/344735

Change 344736 had a related patch set uploaded (by Dzahn):
[operations/puppet@production] admins: add goransm to researchers, analytics-wmde, analytics-users

https://gerrit.wikimedia.org/r/344736

If this helps here, I have an WMDE e-mail now: goran.milovanovic_ext@wikimedia.de

Dzahn added a subscriber: Dzahn.Mar 27 2017, 6:37 PM

Thanks. I have updated https://gerrit.wikimedia.org/r/#/c/344735/2/modules/admin/data/data.yaml to use the wikimedia.de address. it is in code review to create the account and it looks we still need the legal approval to merge it.

Thanks! Please note we still have to have legal sign off on this task. (We unfortunately cannot accept simple user confirmation of NDA, but now require legal review.)
Once we have that, everything else is set for authorizations!

@RStallman-legalteam Hi, could you do the sign off above please? Thank you, Daniel

Yes, Goran's NDA is on file. Thanks!

Change 344735 merged by Dzahn:
[operations/puppet@production] admins: create shell account for Goran S. Milovanovic

https://gerrit.wikimedia.org/r/344735

Dzahn added a comment.Mar 27 2017, 7:16 PM

Your user has been created on the bastion host(s). you should already be able to ssh to bast1001.wikimedia.org. now we can add you to additional groups.

Dzahn updated the task description. (Show Details)Mar 27 2017, 7:20 PM
Dzahn updated the task description. (Show Details)

Change 344992 had a related patch set uploaded (by Dzahn):
[operations/puppet@production] admin: add goransm to researchers,analytics-wmde,analytics-users

https://gerrit.wikimedia.org/r/344992

Dzahn claimed this task.Mar 27 2017, 7:28 PM

Change 344992 merged by Dzahn:
[operations/puppet@production] admin: add goransm to researchers,analytics-wmde,analytics-users

https://gerrit.wikimedia.org/r/344992

Dzahn added a comment.Mar 27 2017, 7:50 PM

Hi @GoranSMilovanovic

Your shell account has been created and you have the requested groups. I confirmed on stat1002 you have:

[stat1002:~] $ id goransm
uid=16664(goransm) gid=500(wikidev) groups=500(wikidev),784(analytics-wmde-users)

and on stat1003 you have:

[stat1003:~] $ id goransm
uid=16664(goransm) gid=500(wikidev) groups=500(wikidev),714(researchers)

There are 4 different bastion hosts, you can pick the one closest to you:

https://wikitech.wikimedia.org/wiki/Bastion

Then you will have to connect via bastion hosts to the stats/analytics servers.

Here is some help for getting the right SSH config:

https://wikitech.wikimedia.org/wiki/Production_shell_access#SSH_configuration

Let us know if you have any questions.

Dzahn closed this task as Resolved.Mar 27 2017, 7:51 PM
Dzahn removed a project: Patch-For-Review.

Change 344736 abandoned by Dzahn:
admins: add goransm to researchers, analytics-wmde, analytics-users

Reason:
duplicate of https://gerrit.wikimedia.org/r/#/c/344992/

https://gerrit.wikimedia.org/r/344736