Page MenuHomePhabricator

"Do you want to leave this page?" dialog after saving edit and introducing new URL in browser
Closed, ResolvedPublic8 Estimated Story Points

Description

This bug comes from time to time and I finally took a screenshot to report it. Pity that for some reason the screenshot was cut, but serves as proof anyway.

I am not sure how to replicate this. The sequence of steps is the same, but as far as I am aware it doesn't happen always.

  1. Edit a page (I was editing with VisualEditor-MediaWiki-2017WikitextEditor and this is why I am adding the tag just in case).
  2. Save changes normally. Check that you are in a "read" mode again.
  3. Introduce another URL in the browser, press Enter.

The dialog appears.

This happened with Chromium Version 55.0.2883.75 built on Debian stretch/sid, running on Debian 9.0 (64-bit). The diff, just in case it is useful.

Event Timeline

Qgil created this task.Mar 23 2017, 2:38 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 23 2017, 2:38 PM
Elitre added a subscriber: Elitre.Mar 23 2017, 2:52 PM
Jdforrester-WMF changed the task status from Open to Stalled.May 2 2017, 7:24 PM
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

I think this is the same as T153346, but that was deployed on 14 March (so a week before your bug report) – has it happened to you since then? If not, I'll merge them as duplicates (and write it up to caching issues), if not we've got another one to hunt down. :-(

Qgil added a comment.May 4 2017, 11:11 AM

Yes, keeps happening now and then but now I am not sure whether in the past days has happened in Wikimedia or in my personal wiki, hosted at http://miraheze.org. I'll pay more attention and report here any news.

Jdforrester-WMF set the point value for this task to 8.May 10 2017, 3:58 PM
Qgil closed this task as Resolved.May 19 2017, 1:03 PM
Qgil claimed this task.

I'll mark this as Resolved, since the problem is not appearing anymore. Feel free to adjust to a better resolution. Thank you for the fix!

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMay 19 2017, 1:03 PM