Page MenuHomePhabricator

[betalabs-regression] Flow: The icon for the sorting option 'Newest topics' is missing
Closed, ResolvedPublic

Description

Only in betalabs.

The element "oo-ui-iconElement-icon oo-ui-icon-beta" does not display an icon:

vs. the correct display in testwiki (wmf.17)

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 23 2017, 6:31 PM

It looks like this icon was deleted from oojs-ui in rGOJUf6a4b3c13793: [BREAKING CHANGE] icons: Drop 'beta' and 'ribbonPrize', deprecated in 0.18.3 . I'll put it back in Flow for now, but the fact that it got deleted is probably a sign that we should re-evaluate which icon we use here. @Pginer-WMF ?

Change 345200 had a related patch set uploaded (by Catrope):
[mediawiki/extensions/Flow@master] Add icon for "Newest topics" back

https://gerrit.wikimedia.org/r/345200

Change 345200 merged by jenkins-bot:
[mediawiki/extensions/Flow@master] Add icon for "Newest topics" back

https://gerrit.wikimedia.org/r/345200

Eurgh, that's what T141801 was intended for to provide us broad overview. Should we reconsider it for OOUI as well and if so, under what name, where should it live?

In this context, an alternative from the repo could be the icon could be the icon named "sun".

I think the "new" icon was also used in Content Translation's contribution popup menu to signal that there is a new option (translations).

In this context, an alternative from the repo could be the icon could be the icon named "sun".
I think the "new" icon was also used in Content Translation's contribution popup menu to signal that there is a new option (translations).

I'd be happy to switch to the "sun" icon if you think that's better.

Checked the fix in betalabs - the sun icon is back.

QA Recommendation: Resolve

jmatazzoni closed this task as Resolved.Apr 26 2017, 1:46 AM
jmatazzoni claimed this task.

@Etonkovidova just to verify, it's the OOjs UI sun icon now?