Page MenuHomePhabricator

Enable VisualEditor by default for all users of the Dutch Wikipedia
Closed, ResolvedPublic8 Estimate Story Points

Description

RequirementStatus
Option to switch between source and visual editing modes, w/o losing changes
Prompt to choose between source and visual editing modes when opening the editor for the first time
In preferences, option to opt-out of the visual editing mode, so only one edit tab is shown
In preferences, option to make visual editing mode your preferred option.Not needed per T161365#5849523
Clicking "Edit" should open the visual editing mode
Clicking "Edit source" should open the source editor mode
Anonymous users should be able to access visual editing mode in the same ways as logged in users (e.g. switching, two edit tabs)
Visual editing mode should be available on article pages, and in the User, Wikipedia and Help namespace.
Visual editing mode should NOT be available on discussion pages.

Details

Related Gerrit Patches:
operations/mediawiki-config : master[nlwiki] Enable VisualEditor in the Project namespace
operations/mediawiki-config : master[nlwiki] Enable VisualEditor by default for all users

Event Timeline

AdHuikeshoven added subscribers: Natuur12, Romaine, Mbch331.
Jdforrester-WMF set the point value for this task to 8.Apr 24 2017, 5:29 PM
Jdforrester-WMF removed Jdforrester-WMF as the assignee of this task.Feb 21 2018, 7:14 PM

Change 566866 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[operations/mediawiki-config@master] [nlwiki] Enable VisualEditor by default for all users

https://gerrit.wikimedia.org/r/566866

Change 566866 merged by jenkins-bot:
[operations/mediawiki-config@master] [nlwiki] Enable VisualEditor by default for all users

https://gerrit.wikimedia.org/r/566866

Mentioned in SAL (#wikimedia-operations) [2020-02-04T00:06:15Z] <jforrester@deploy1001> Synchronized dblists/visualeditor-nondefault.dblist: [nlwiki] Enable VisualEditor by default for all users T161365 (duration: 00m 58s)

Thank you for your help on this, @Jdforrester-WMF; I reviewed nl.wiki's requirements [1] and it seems there are two pieces of unexpected behavior and one behavior that we need more details about before we can test.

Unexpected behavior

  1. In preferences, option to make visual editing mode your preferred option: ⚠️There doesn't seem to be an "Edit mode" dropdown in Preferences > Editing on nl.wiki as there is on en.wiki
  2. Visual editing mode should be available on article pages, and in the User, Wikipedia and Help namespace: ⚠️Visual editing mode does not seem to be enabled in the Wikipedia namespace [2]

Behavior needing more details

  1. Visual editing mode should NOT be available on consultation pages: Pending confirmation from @Whatamidoing-WMF

Full requirements [1]

RequirementStatus
Option to switch between source and visual editing modes, w/o losing changes
Prompt to choose between source and visual editing modes when opening the editor for the first time
In preferences, option to opt-out of the visual editing mode, so only one edit tab is shown
In preferences, option to make visual editing mode your preferred option.⚠️There doesn't seem to be an "Edit mode" dropdown in Preferences > Editing on nl.wiki as there is on en.wiki
Clicking "Edit" should open the visual editing mode
Clicking "Edit source" should open the source editor mode
Anonymous users should be able to access visual editing mode in the same ways as logged in users (e.g. switching, two edit tabs)
Visual editing mode should be available on article pages, and in the User, Wikipedia and Help namespace.⚠️Visual editing mode does not seem to be enabled in the Wikipedia namespace [2]
Visual editing mode should NOT be available on consultation pages.Pending confirmation from @Whatamidoing-WMF

  1. https://nl.wikipedia.org/wiki/Wikipedia:Opinielokaal/Inschakelen_visuele_tekstverwerker
  2. I'm not seeing two edit tabs enabled on this page: https://nl.wikipedia.org/wiki/Wikipedia:Beginnetje. Note: I am logged in and the "Temporarily disable visual word processor as long as it is in beta" editing preference is disabled.
Whatamidoing-WMF added a comment.EditedFeb 4 2020, 9:03 PM

There isn't an "Edit mode" dropdown because it's not a https://www.mediawiki.org/wiki/VisualEditor/Single_edit_tab wiki. We set those up for a while. It was okay-but-not-great, so the team put the project down for a bit, with the idea of getting back to it later/with the benefit of a little more distance/perspective/time to think it over. Nothing's happened since then.

The Dutch Wikipedia has the (older) system that's used at the German Wikipedia: https://de.wikipedia.org/wiki/Spezial:Einstellungen#mw-prefsection-editing

The community vote specified enabling it in the Wikipedia: (Project:) namespace, so that should be corrected. See also T164435 and T159711, which are older requests for that change.

It should not be enabled on discussion pages (e.g., Overleg_Wikipedia: or Project_talk:). This part of the config is already correct.

Change 570419 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[operations/mediawiki-config@master] [nlwiki] Enable VisualEditor in the Project namespace

https://gerrit.wikimedia.org/r/570419

Change 570419 merged by jenkins-bot:
[operations/mediawiki-config@master] [nlwiki] Enable VisualEditor in the Project namespace

https://gerrit.wikimedia.org/r/570419

Mentioned in SAL (#wikimedia-operations) [2020-02-06T23:22:42Z] <jforrester@deploy1001> Synchronized wmf-config/InitialiseSettings.php: T159711 T161365 T164435 [nlwiki] Enable VisualEditor in the Project namespace (duration: 01m 08s)

ppelberg updated the task description. (Show Details)Feb 17 2020, 7:13 PM
ppelberg updated the task description. (Show Details)

There isn't an "Edit mode" dropdown because it's not a https://www.mediawiki.org/wiki/VisualEditor/Single_edit_tab wiki. We set those up for a while. It was okay-but-not-great, so the team put the project down for a bit, with the idea of getting back to it later/with the benefit of a little more distance/perspective/time to think it over. Nothing's happened since then.
The Dutch Wikipedia has the (older) system that's used at the German Wikipedia: https://de.wikipedia.org/wiki/Spezial:Einstellungen#mw-prefsection-editing

Ah, understood. Thank you for clarifying, Sherry.

I've updated the task description to include, what I currently understand to be, the requirements the nl.wiki defined and whether those requirements have been met or not.

Next step

  • @Whatamidoing-WMF, can you please confirm whether the requirements and their corresponding statuses listed in the task description are accurate?
Whatamidoing-WMF closed this task as Resolved.Feb 24 2020, 6:20 PM
Whatamidoing-WMF updated the task description. (Show Details)

The last few details have all been fixed. We're done.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptFeb 24 2020, 6:20 PM