Page MenuHomePhabricator

Adding RTF features in 'Email this user'
Closed, DeclinedPublic

Description

Abstract

The objective of this project is to add rich text formatting to 'Email this user' in order to utilise 100% of the email feature.

Personal details

*Name: Agastya Chandrakant
*E-mail: acagastya@gmail.com; acagastya@outlook.com
*IRC nick: acagastya; acagastya-afk (@irc.freenode.net)
*Country of residence: India (IN)
*Timezone: UTC+0530 (Indian Standard Time)
*Resumé link: Google Docs link
*Typical working hours: 2 AM to 8 AM IST (I may need to change: 2030 - 0230 UTC)

Proposal

'''Synopsis:''' I propose to add Rich Text Formatting features for '‘Email this user' feature.

Detailed explanation

'Email this User' is one of the amazing features, which, in my opinion requires development. It helps in the communication, but currently, it doesn't support Wiki Markup or styling/formatting, which makes certain things difficult. (Personally, I do not like the plain text without any formatting.) There should be rft for the mails, I think.

Why do I think it is required?

There are three ways to communicate with other editors: talk page, IRC, and email. Evidently, talk page is not always the first choice means. And thus, we rely on emails and IRC. There are some drawbacks of IRC, like what if the other editor is not available on IRC and thus, we need emails. But without the option of formatting the text, we are not utilising 100% of this feature, and without an option to hyperlink, things become difficult and the mail becomes inelegant. Plus, when the user is reading the mail from a mobile device, selecting URL and opening it in a browser is not so straightforward.
From the visual appeal to the text formatting, everything affects our words and thoughts for the response, if we choose to. It is one of the vital features we are missing out.

What I wish to do?

Most of the editors who communicate via 'Email this User' are aware of the Wiki Markup syntax. My primary goal is to bring the feature of rtf, just like how we have in popular email providers. (B, I, <U>U</U>)
If time permits, I would like to add the option to use Wiki Markup for the Email feature, so the editors can write mails just like how they contribute to the community.

Schedule of Deliverables

Looking at this year's Google Summer of Code's timeline, I have approximately thirteen weeks to complete the project satisfactorily.

Initially, during the community binging period, I will have my semester end exams. To compensate, I have scheduled to through the source code of the 'Email this User' from March 26.

Till May

Thorough understanding of the dependencies and needs of 'Email this User'. Exploring, and detailed study for the design and philosophy of the feature.

Official GSoC period

*Tackling the issue of current email feature, and integrating the design of Echo notifications.
*Adding the Rich Text Format options to the mails.
*Adding HTML elements* to the mails.
*Documentation; thoroughly updated on weekends.
*Please note that the primary objective of this project is to add Rich Text Formatting to the mail, and I plan to add HTML elements if it seems feasible.
*If time permits: Adding Wiki Markup feature and improving the the notification mails from wiki@wikimedia.org.
**I will be able to provide detailed information before May.

Participation in free knowledge and FOSS projects

Since August 2014, I have been contributing to Wikimedia projects, like Wikipedia, Wikinews, Wikimedia Commons, Wikibooks, and, Wikidata. My contributions are licensed under Creative Commons Attribution Share-Alike (CC BY-SA) license (except for the edits on Wikidata project, which uses CC0 1.0/ Public Domain)

On Wikinews (and Wikipedia), apart from the content editing, I have designed templates from scratch. I have also re-designed templates which were not designed for the mobile website and did not serve the purpose previously.

I have submitted bug reports and fixes for templates on their talk pages.

I have submitted a patch for Mozilla Thunderbird recently.

Participation for this project

My primary mode of communication will be IRC, I rarely disconnect from IRC. I will be discussing with the mentor, asking for hep, and proposing design change on IRC. But, if the mentor is not available on the IRC, I will use the 'Email this user' feature from MediaWiki's Special:EmailUser.

I would prefer to publish the source code on GitHub.

About me

I am a second semester student, and my semester end exams are to be finished at the end of May. I do not have any other plans for vacation. I spend hours on Wikimedia projects, and this project will come naturally. Last summer, I had a busy schedule because of the college admission process, but I was able to write fifty news article in June and July on Wikinews. And thus, I believe, when I have no other activities for this summer, I can deliver the output for this project.

To answer for "What makes you want to make this the most awesomest wiki enhancement ever?", I use 'Email this user' feature a lot. And sometimes, without the option of text formatting, and creating hyperlinks, the email looks untidy. If it is for me, I believe it is for others, and I want to improve the user experience.

"Am I a Wikipedia addict?" No. I am not. Am I a Wikimedia project addict? I won't swear, so I will just say YES, I am. I spend hours on Wikimedia projects. I started as a Wikipedian, but later moved to the other Wikimedia projects. Free knowledge was the reason I chose WIkimedia Foundation and that is the reason I am with Wikimedia Foundation till now.

Past experience

there are two type of bugs. The ones on MediaWIki software. No, I have not reported/fixed any bugsin the software. The ones, which exists on the WIkimedia project's templates. Yes, I have dealt wit them, and fixed some of them. This afternoon, I flagged a template on WIkinews which was not rendering properly on the mobile site, which I will be looking after soon.

'''Summary:''' Designing, creating templates, and scripts for Wikimedia projects, designing and creating school website and bug reporting/fixing on Launchpad
Most of my work, on-wiki, is under Creative Commons license, and I use Creative Commons license, even in my day-to-day life. Some of my works on WIkimedia projects, apart from writing and/or editing articles are:

Recently improvised/designed templates on English Wikinews

Translation note

https://en.wikinews.org/wiki/Template:Translation_note did not work on mobile device.
The challenge was to re-design the template (which is a tooltip) without using JavaScript, as JavaScript can be disabled in some web browsers. Several times, the JavaScript of the website is down, and thus, the template would fail to serve it purpose in that time interval.
It was designed in pure CSS to tackle the issue. https://en.wikinews.org/wiki/MediaWiki_talk:Common.css#Editprotected

UEFA Euro 2016

Last year, for the associate football tournament, UEFA Euro 2016, I made a template, (infobox) which was different from other infoboxes currently used on the website. The template uses <DynamicPageList> element to list the latest news articles in the same category. The template uses the colour scheme of the tournament, and at the same time, not compromising with the website's environment.

Donut (edited using IP address)

This template https://en.wikinews.org/wiki/Template:Donut was one of the most complicated templates I had to deal with. It is used to create a donut chart for two values. The tricky part comes that the parameters are to be handled differently for different browsers. It also relies on a helping template, called prefix https://en.wikinews.org/wiki/Template:Prefix to deal with the prefix of CSS for various browsers.

Front-End Development Experience (not licensed under Creative Commons)

I have re-designed and helped building my school's website http://aecskak.ac.in/, which was previously static (SHTML).

Trivial Open Source contribution on Launchpad

I have reported a couple of bugs on Launchpad, for Elementary OS https://bugs.launchpad.net/~acagastya, and I am currently working on them.

Other information/See also

A link for my global Wikimedia participation: https://tools.wmflabs.org/guc/index.php?user=Acagastya&blocks=true; https://tools.wmflabs.org/guc/index.php?user=Agastya&blocks=true. I have about 8700 edits from the registered accounts.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 28 2017, 8:26 AM
Aklapper added a project: MediaWiki-Email.EditedMar 28 2017, 1:06 PM

Thanks for the idea and for creating this task!

*Please note that the primary objective of this project is to add Rich Text Formatting to the mail, and I plan to add HTML elements if it seems feasible.

I don't understand, I'm afraid... So "Rich Text Formatting" does not mean "HTML formatting"?
Is "Rich Text Format" an email format I have not heard of? :) If so, please link to a email format specification / RFC for RTF. For example, https://en.wikipedia.org/wiki/Rich_Text_Format (if that is the same thing) does not imply that RTF is an email format.

T135484 and T15303 come to my mind.

My primary goal is to bring the feature of rtf, just like how we have in popular email providers. (B, I, <U>U</U>)

Have you checked out the VisualEditor or https://www.mediawiki.org/wiki/2017_wikitext_editor , as potential backends?

I would prefer to publish the source code on GitHub.

Note that we mostly (but not exclusively) use Wikimedia Git/Gerrit. If you have not checked out Gerrit, I recommend to do so, also in order to provide a patch for a microtask. :)

@Aklapper RTF is a proprietary file format, which has the features like bold, italics, underline and hyperlink. I did not say HTML formatting because an HTML email is a different concept, and that shifts the focus of the project.

I am aware of the Visual Editor. But unfortunately, neither VE or personal/website's JavaScript is working for one of my accounts, and thus, I do not generally use VE as the preferred choice of editor.

I am aware of Gerrit. And if it is what Wikimedia wants, I don't have any problem publishing the source code there.

I would also like to stress upon this point that we can disable JavaScript in certain web browsers, and so, the approach should not be similar to VE.

As RTF is a file format, how is RTF related to email? Has RTF become a standardized email format at some point? If so, please provide pointers. :)
If the underlying problem to solve is to allow text formatting in emails, then using HTML is widely supported by email clients, so I'm wondering why RTF is proposed.

@Aklapper
RTF is not an email format. But RTF offers features like underlined, bold, and italicised text. Other features like hyperlink, bullet list, numbering, text alignment, et cetera (<Screenshot>)

This is different from the HTML email. <screenshot>, <Screenshot>.

HTML formatting is supported in many email clients, an HTML email looks like a promotional email, where we have lot of photos, logos, and flashy buttons with hyperlinks. That is not what one wants while sending/receiving a wiki's email. Even though we can restrict all of these features in the HTML mail, focusing on the simple, spick and span design with the features to Bold, Italics, Underline, hyperlink,, bullet list, font size (...) adding unnecessary* HTML features for wikimail would not be a good idea.

Another point, the endusers will see this as the formatting options (like these facilities), but at the back end, it will be handled by light weight HTML email feature.

*Note that by "unnecessary HTML features for wiki mail", I mean avoiding flashy buttons and other customisation which ends up looking a promo email. <screenshot>

RTF is not an email format.

Maybe what you call "RTF features" are just some HTML features?
If so, you may not want to use the term "RTF features" to avoid confusion, especially if the actual RTF file format is entirely unrelated to this proposal.

an HTML email looks like a promotional email, where we have lot of photos, logos, and flashy buttons with hyperlinks.

That is not generally true but depends on which HTML features are used by the person/application creating an HTML email.

I'm proposing to decline this task, as I'm still missing a description of an underlying problem to solve which cannot be solved by HTML email...

In a nutshell: HTML email gives a lot of option and it can be easily misused to spam and annoy lot of Wikimedians.

Aklapper closed this task as Declined.May 13 2017, 4:34 PM

Email, gives a lot of option and can easily be misused, no matter in which format. If you don't want some HTML features, don't allow or use some HTML features. As easy as that - no need to propose "RTF" format for emails when RTF is not even an email format.
As no new arguments are offered, I'm declining this task for the time being. I hope you'll find some other interesting Wikimedia tasks to work on! :)

I had already discussed with a Wikimedian about why "RTF" was not the most suitable word. I had modified my proposal accordingly. Well, GSoC's selected participants were announced. So this discussion is for anyone who wants to know what they should focus on.

Indeed. I'd propose to focus on https://phabricator.wikimedia.org/T15303 as that seems to get some more traction. :)

Now here is the part: Using the Wiki Markup in the email is not entirely HTML email. And that is what I wanted to do - but then, instead of using the markup, I wanted to make things easier. Just like the Bold Italics and other formatting options available in the comment box, I wanted that for email. Preferably with keyboard shortcuts. HTML Email provides a greater degree of customisation something that will be too much instead of Wiki Markup when two users are communicating via email this user feature.

I think you're confusing some things here. RTF is a proprietary file format for text documents which allows various types of formatting to be added to plaintext; it has nothing to do with email. The formatting options you highlighted above in your screenshot of the Gmail interface are not RTF or anything of the sort (rather, that interface is something normally called a WYSIWYG - What You See Is What You Get - where you are shown the document as it will appear to viewers, as you are editing the document); rather, to send an email with formatting applied to the text like that, the email must be HTML - plain text and HTML are the only email formats which have been standardized and which are supported by email clients. While it's certainly possible that the email interface of MediaWiki could support some subset of wiki markup for the purpose of writing emails, that would have to be converted to HTML before the email was actually sent, and the email's recipient could not also use wiki markup to respond unless there was a system for reading/responding to emails on-wiki (which is a completely separate, and considerably more involved, project).

Acagastya added a comment.EditedMay 14 2017, 3:32 AM

@Dinoguy1000 Thanks for your comment, but was already discussed on IRC about it. I am aware of What You See Is What You Get - but in my project, I wanted to integrate the Wiki Markup but that should not be the only way to format the text.

About "RTF": It was discussed on IRC long back. Can you please not mention that again? It was for "Rich" Text Formatting. Notice the Rich is in double quotes for it was just to say the text in the mail you receive can be formatted -- not necessarily be the plain text.

I only mentioned it to cover all my bases, to be thorough in my comment. If no one else brings it up again, I have no cause to revisit it myself.

Given the way the winds seem to be blowing regarding the long-term future of wiki markup, I personally question whether it would be wise to build an email interface allowing it to be used, instead of just providing a WYSIWYG editor alongside a plaintext editor, or something similar.

I can explain why Wiki Markup is something MediaWiki should not discard, its advantages and user convenience, but this is not the correct place to.
It is on the developers what they want to do.
There are so many important tools which should have been in existence years ago like semi-automated assistance to edit articles, but were never discussed.