Page MenuHomePhabricator

Password reset link missing on mediawiki.org
Closed, ResolvedPublic

Event Timeline

Tgr created this task.Mar 30 2017, 9:14 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 30 2017, 9:14 PM
Tgr added a comment.Mar 30 2017, 9:20 PM

This seems to be a side effect of T154698: Prevent contributions attributed to private and WMF IP addresses:

tgr@terbium:~$ mwscript eval.php --wiki=mediawikiwiki
> $passwordReset = new PasswordReset( RequestContext::getMain()->getConfig(), \MediaWiki\Auth\AuthManager::singleton() );

> $status = $passwordReset->isAllowed( new User);

> return $status->isOK() ?: Status::wrap( $status )->getMessage()->toString();
Your IP address is blocked from editing. To prevent abuse, it is not allowed to use password recovery from this IP address.

I'm not sure why it works on the English Wikipedia, which should suffer from the same issue.

Aklapper triaged this task as High priority.Mar 31 2017, 7:57 AM

I cannot reproduce this anymore in a private browser window with the two links provided in the task description.
Can you? Or should this task be closed as declined?

Tgr added a comment.Apr 30 2017, 5:37 PM

Uh, sorry, I forgot about this completely :(
Still reproducible from the WMF network.

Change 351135 had a related patch set uploaded (by Gergő Tisza; owner: Gergő Tisza):
[mediawiki/core@master] Do not disable password reset for blocks meant to force login

https://gerrit.wikimedia.org/r/351135

Change 351135 merged by jenkins-bot:
[mediawiki/core@master] Do not disable password reset for blocks meant to force login

https://gerrit.wikimedia.org/r/351135

Tgr closed this task as Resolved.Jun 8 2017, 4:08 PM
Tgr claimed this task.