Page MenuHomePhabricator

Search dashboard: remove regex in ZRR breakdown by type
Closed, ResolvedPublic1 Story Points

Description

I don't think this query type is something interesting to have in this dashboard. It's a very technical query and having zero result is not really a failure here.
I'm requesting its removal mostly because it is extremely volatile and makes reading other metrics very hard.

Event Timeline

dcausse created this task.Mar 31 2017, 8:36 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 31 2017, 8:36 AM
mpopov set the point value for this task to 1.Mar 31 2017, 6:09 PM
mpopov added a subscriber: mpopov.

Makes sense! However, we should keep it in the data just in case but hide on the graph and have a toggle for showing it again. That way it's still there if someone wants to see it (for diagnostics or whatever).

mpopov claimed this task.Mar 31 2017, 6:17 PM
mpopov moved this task from Backlog to In progress on the Discovery-Analysis (Current work) board.

This is gonna take like 10 minutes at most so I'm just gonna bust this out real quick :)

Change 345875 had a related patch set uploaded (by Bearloga):
[wikimedia/discovery/rainbow@master] Hide regex searches' ZRR

https://gerrit.wikimedia.org/r/345875

mpopov added a subscriber: chelsyx.

Waiting for CR from @chelsyx (who's off today and won't be able to get to it until Monday), up on beta in the meantime: https://discovery-beta.wmflabs.org/metrics/#failure_breakdown

@dcausse: are you okay with this solution?

@mpopov thanks, this is perfect!
We can now quickly spot small anomalies: e.g. the small ZRR spike in prefix around March 20 (caused by the upgrade to elsatic5 when we disabled the completion suggester)

Change 345875 merged by Bearloga:
[wikimedia/discovery/rainbow@master] Hide regex searches' ZRR

https://gerrit.wikimedia.org/r/345875

Change 346598 had a related patch set uploaded (by Bearloga):
[wikimedia/discovery/dashboard@master] Deploy making regex ZRR optional

https://gerrit.wikimedia.org/r/346598

Change 346598 merged by Bearloga:
[wikimedia/discovery/dashboard@master] Deploy making regex ZRR optional

https://gerrit.wikimedia.org/r/346598

debt closed this task as Resolved.Apr 7 2017, 7:34 PM
debt awarded a token.