Page MenuHomePhabricator

ORES swagger doc based API requests do not work
Closed, ResolvedPublic

Description

The API sandbox for ORES sends requests over HTTP instead of HTTPS and doesn't work because of this. Happens on Safari 10 on OS X, not sure if it's browser specific.

Details

Related Gerrit Patches:
mediawiki/services/ores/deploy : masterChange swagger scheme to SSL

Event Timeline

Pchelolo created this task.Apr 4 2017, 6:56 PM
Restricted Application added a project: Scoring-platform-team. · View Herald TranscriptApr 4 2017, 6:56 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Halfak assigned this task to Ladsgroup.Apr 12 2017, 10:41 PM
Restricted Application added a project: User-Ladsgroup. · View Herald TranscriptApr 12 2017, 10:41 PM
Halfak added a subscriber: Halfak.Apr 12 2017, 10:42 PM

I think the problem here is that we detect the protocol used in the URL and set that to the protocol available in swagger. For some reason, we get http even when the request is https. This is probably due to varnish or some other weird intermediary.

I doubt that. It's broken even in labs: https://ores.wmflabs.org/v2

You're right, but I think we'll still have the http/https problem after this gets merged.

I've pulled this task back into review because I'd like to see it deployed and working before we declare victory.

Confirmed that the sandbox still doesn't work. It's making requests to the http and that's not returning data.

I see. I get it fixed soon (sorry for the comment made too soon)

Halfak renamed this task from ORES API sandbox doesn't work to ORES swagger docs do not work.Apr 27 2017, 1:40 PM
Halfak renamed this task from ORES swagger docs do not work to ORES swagger doc based API requests do not work.
Halfak moved this task from Review to Done on the Scoring-platform-team (Current) board.
Halfak closed this task as Resolved.Jun 5 2017, 5:07 PM

Change 357331 had a related patch set uploaded (by Ladsgroup; owner: amir):
[mediawiki/services/ores/deploy@master] Change swagger scheme to SSL

https://gerrit.wikimedia.org/r/357331

Ladsgroup reopened this task as Open.Jun 6 2017, 12:09 AM
Ladsgroup moved this task from Done to Review on the Scoring-platform-team (Current) board.

Change 357331 merged by Halfak:
[mediawiki/services/ores/deploy@master] Change swagger scheme to SSL

https://gerrit.wikimedia.org/r/357331

Confirmed that they work now :)

Halfak closed this task as Resolved.Jul 12 2017, 10:49 PM