Page MenuHomePhabricator

Update nightlies with prepackaged 3.x releases
Closed, ResolvedPublic

Description

http://tools.wmflabs.org/pywikibot/core_stable.zip is a one-download package, which includes httplib2, so that users just have to unpack it (and no further installation is necessary). If possible, we should to the same for the 3.x releases. This might mean differend packages for different operating systems (not sure). In that case, we should focus on Windows, and ask Linux/OS X users to just 'pip install pywikibot'.

I'm not entirely sure what the dependencies are -- requests (and all its dependencies), but possibly also others?

Event Timeline

Restricted Application added subscribers: pywikibot-bugs-list, Aklapper. · View Herald TranscriptApr 9 2017, 7:48 PM
Xqt added a subscriber: Xqt.Apr 9 2017, 8:04 PM

only requests is necessary in a first step which replaces httplib2 for pwb 3.0. It is very simple for Windows user to "pip install requests"; I guess pip is included since py 2.7.10+

Xqt closed this task as Resolved.Oct 19 2017, 7:20 AM
Xqt claimed this task.

I think this is already done in http://tools.wmflabs.org/pywikibot/ and pwb 3 is availlable

Xqt removed Xqt as the assignee of this task.Oct 19 2017, 7:20 AM