Page MenuHomePhabricator

JavaScript errors on https://de.wikipedia.org/wiki/Spezial:Verschieben
Closed, InvalidPublic

Description

On Firefox https://de.wikipedia.org/wiki/Spezial:Verschieben/Wikipedia:Spielwiese?debug=true throws

Error: Widget not found: wpNewTitle

on https://de.wikipedia.org/w/resources/lib/oojs-ui/oojs-ui-core.js?c7da5 line 691.

Maybe related: The gadget https://de.wikipedia.org/wiki/MediaWiki:Gadget-old-movepage.js loads the module 'mediawiki.special.movePage'.

Event Timeline

Fomafix created this task.Apr 11 2017, 7:45 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 11 2017, 7:45 AM
Fomafix updated the task description. (Show Details)Apr 11 2017, 8:57 AM

I can reproduce the second error on a local installation. Therefor I created the separate task T162667.

I first error is related on the gadget because it loades the module 'mediawiki.special.movePage'. The module should be more robust so it does not throw an error.

I don't think this is a MediaWiki bug. 'mediawiki.special.movePage' indeed requires the #wpNewTitle element to be present on the page, but it can do that, because that element is normally always present. I don't actually see how this problem could be happening, hm…

Fomafix closed this task as Invalid.Apr 12 2017, 10:14 PM

In https://de.wikipedia.org/wiki/MediaWiki_Diskussion:Gadget-old-movepage.js#Gadget_funktioniert_nicht I created a variant of the gadget which loads the module only when the elements are present. This should avoid the error of this task. Of course the gadget can still improved.

Invalid. Not a bug in MediaWiki.