Page MenuHomePhabricator

When you search for a filter and add it, then click on an already active filter, the filter list is not updated
Closed, ResolvedPublic

Description

Example, based on the default settings

  1. search for a filter in the list, for example "newcomers"
  2. the filter is the only one displayed in the Filter search bar, choose it. The Dropdown filter panel has "newcomers" displayed only.
  3. click on "human"
  4. the Dropdown filter panel is not displaying "human"

Should it display "human" to ease the search and then, should it clear the Filter search bar?

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 11 2017, 3:50 PM

Hi @Trizek-WMF. Please associate at least one project with this task to allow others to find this task when searching in the corresponding project(s). Thanks!

Hi @Trizek-WMF. Please associate at least one project with this task to allow others to find this task when searching in the corresponding project(s). Thanks!

Shame on me.

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptApr 11 2017, 4:07 PM

To clarify, what you need to do to reproduce this bug is:

  • Make sure filter A (in this case, "human") is active
  • Type (part of) the name of filter B into the search box, so it is the only search result
  • Choose filter B
  • Click on the capsule for filter A
  • Expect filter A to be scrolled to; but it won't be, because it's not visible in the menu

@Mooeypoo Does your TagMultiselectWidget-based rewrite address this issue by any chance?

Mooeypoo claimed this task.Apr 12 2017, 6:49 PM

To clarify, what you need to do to reproduce this bug is:

  • Make sure filter A (in this case, "human") is active
  • Type (part of) the name of filter B into the search box, so it is the only search result
  • Choose filter B
  • Click on the capsule for filter A
  • Expect filter A to be scrolled to; but it won't be, because it's not visible in the menu

@Mooeypoo Does your TagMultiselectWidget-based rewrite address this issue by any chance?

It does now.

Change 344997 had a related patch set uploaded (by Mooeypoo):
[mediawiki/core@master] RCFilters: Adjust to use MenuTagMultiselectWidget

https://gerrit.wikimedia.org/r/344997

The search criteria is not dismissed when a filter selection is made from the suggestion list. So, when a capsule is clicked, the list of suggested filters is displayed again.

Change 344997 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Adjust to use MenuTagMultiselectWidget

https://gerrit.wikimedia.org/r/344997

Etonkovidova added a comment.EditedApr 17 2017, 8:11 PM

The fix is in place - checked in betalabs.

Steps (to follow the steps described in the ticket):

  • Select 'Human (not bot)' filter
  • Type 'new' (no quotes) in the Search filter area - the suggested 'Newcomers' filter will be displayed in the list of suggested filters. Select 'Newcomers' filter.
  • Click outside the dropdown panel to discard it. Then click on 'Human (not bot)' capsule filter - the dropdown filter panel will display filters with highlighted 'Human (not bot)' and the Search area will be cleared out from previous search entries.

There is T163138: [betalabs-regression] RC filters - in drop down filter panel there is no automatic scrolling to selected filter capsule which makes verifying the fix a little bit difficult, but following the above steps confirms the fix.

QA Recommendation: Resolve

jmatazzoni closed this task as Resolved.Apr 19 2017, 8:12 PM
jmatazzoni added a subscriber: jmatazzoni.

The question is whether we want to remove the search word when you a) click to get the filter, or b) click