Page MenuHomePhabricator

[spike 2hrs] Evaluate result of "Log instances of infoboxes being wrapped in containers" (T149884 )
Closed, ResolvedPublic

Description

Evaluate result of T149884 and determine whether a specialized solution for these cases is needed

  • Create tasks for any bugs that are found. T163805 has been created.
  • Submit fixes for those bugs if they are really quick fixes (< 2 hours). Identified issues don't seem to be easily fixable.
  • Communicate to Olga whether any of these bugs may block deployment and why Commented at T162713#3210834

Timebox: 2hrs

Event Timeline

Jdlrobson renamed this task from Evaluate result of T149884 to [spike] Evaluate result of T149884 .Apr 11 2017, 4:27 PM
Jdlrobson added a project: Spike.
Jdlrobson updated the task description. (Show Details)
phuedx updated the task description. (Show Details)Apr 11 2017, 4:28 PM
Jdlrobson renamed this task from [spike] Evaluate result of T149884 to [spike] Evaluate result of lead paragraph logging T149884 .Apr 13 2017, 7:00 PM
ovasileva renamed this task from [spike] Evaluate result of lead paragraph logging T149884 to [spike 2hr] Evaluate result of "Log instances of infoboxes being wrapped in containers" (T149884 ).Apr 19 2017, 5:40 PM
ovasileva renamed this task from [spike 2hr] Evaluate result of "Log instances of infoboxes being wrapped in containers" (T149884 ) to [spike 2hrs] Evaluate result of "Log instances of infoboxes being wrapped in containers" (T149884 ).

I moved this task to "Blocked externally" as we don't have lots of data yet. Let's wait till next half of current sprint and then review logs.

bmansurov moved this task from To Do to Doing on the Reading-Web-Sprint-96 board.
bmansurov added a comment.EditedApr 25 2017, 5:31 PM

I see a little more than 2,000 instances of message:"Found infobox wrapped" at over the last 10 days. Here are some of the page titles logged in logs:

False alarms

  1. Rodney Peete - false alarm as the infobox is a direct child of the lead section and the page was last edited 25 days ago while the log entry was created today;
  2. LNER_Class_A4_4468_Mallard;
  3. 香水 - no infobox on the page;
  4. Portal:Current_events - Considering the page is laid out using tables, I wonder if we need to worry only articles in the Main namespace;
  5. Bob_Hope_Airport

Correctly identified problematic pages

  1. Strongyloides_stercoralis - template is wrapped in a div;
  2. Nematode - template is wrapped in a div
  3. Pinworm_(parasite) - template is wrapped in a div
  4. سیب‌زمینی - template is wrapped in a div

Communicate to Olga whether any of these bugs may block deployment and why

@ovasileva I don't think any the identified issues block deployment as the issues are related to logging only (and not to UX). Logging helps us identify infoboxes that are wrapped in containers so that we can update their templates accordingly. Having some (false) information about infoboxes that are not wrapped in a container is not a blocker.

bmansurov updated the task description. (Show Details)Apr 25 2017, 5:49 PM
bmansurov moved this task from Doing to Needs Code Review on the Reading-Web-Sprint-96 board.
Jdlrobson added a subscriber: Jdlrobson.EditedApr 26 2017, 3:25 PM
  • Why have we got false alarms? I'd like to understand those. Were there revisions with wrapped infoboxes that were removed?
  • For the "Correctly identified problematic pages" how is the wrapping occurring? Via Template or manually?
  • For the "Correctly identified problematic pages" is the infobox template being misused for another purpose?
  • For the "Correctly identified problematic pages" does the infobox container have any other children?
  • For the "Correctly identified problematic pages" what would be the problem with moving the infoboxes above the lead paragraphs?

I've updated my original comment at T162713#3210784 to include more info. In general templates are being wrapped in a div.

I've also updated the description of T163805 with more info on why logging is happening.

Thanks @bmansurov! I've left a message on the talk page - it seems given there are just 2 templates involved we can hopefully get these fixed and see if the noise is reduced.

I'm reading through T163805 and seeing if I can find out what the root cause of the 香水 example is but your recommendations there look great.
Aiming to finish this by the end of the day.

T163805 the output of this task looks like it's in great shape.

I'm going to sign off as soon as I get an answer with regards to https://phabricator.wikimedia.org/T163805#3216401 as I think 香水 was a red herring and I think the other two issues are well captured. @bmansurov please re-assign to me once you've confirmed either way? Thanks!

bmansurov reassigned this task from bmansurov to Jdlrobson.Apr 27 2017, 5:43 PM

I've updated T163805.

Jdlrobson closed this task as Resolved.Apr 27 2017, 5:52 PM

Thanks @bmansurov! T163805 is looking very clear.

@ovasileva my recommendation is that we address T163805 in next sprint before enabling the lead paragraph experiment to increase our confidence of deploying this.
Signing off!