Page MenuHomePhabricator

Lift IP cap for 186.179.xxx.xx (ongoing hackathon)
Closed, InvalidPublic

Description

What I know about this is at
https://www.wikidata.org/wiki/Wikidata:Project_chat#Can_anyone_here_help_sort_out_presumed_IP_ban_for_ongoing_Wikidata_hackathon_in_Suriname.3F
and
https://lists.wikimedia.org/pipermail/wikidata/2017-April/010580.html .
I have also tried the IRC channels wikimedia-stewards, wikidata and wikimedia-tech, and at the latter, it was suggested that I try Phabricator, so here we go.

Event Timeline

Restricted Application added a project: Cloud-Services. · View Herald TranscriptApr 11 2017, 10:21 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

What's the specific IP address that needs whitelisting?

Also please provide the specific error message that is being seen - can they not create new accounts? Or is it editing at all? The latter would be a different issue unrelated to the IP account creation cap.

They have created accounts but cannot edit. I am not not there. IP is 186.179.xxx.xx .

They have created accounts but cannot edit.

If they cannot edit, please explain why (and what exactly happens / is shown when they try), so someone could help. Also see https://mediawiki.org/wiki/How_to_report_a_bug - thanks!

There were indeed two issues. After a few first new accounts (6 or 8) no more new accounts could be created. I did not capture the exact error message, but it was more less indicating that after that number, it was no longer possible to create new accounts. This was fixed by creating the accounts through the mobile devices of the various participants.

However, immediately after that issue, it was not possible to make annonymous edits, nor edits from new accounts. I however could continue editing as have I done before. So it seems that there was a ban on new users.
The ban was visible in two ways. There was a little lock in the top right corner and there were also no "edit..." links available. The IP address of one of the machines was: 186.179.232.94

There was a little lock in the top right corner and there were also no "edit..." links available.

What page specifically? The lock usually means the page is protected against unregistered/new users editing it.

There were indeed two issues. After a few first new accounts (6 or 8) no more new accounts could be created.

This issue is coherent with our configuration. To create more than 8 accounts, you need to request we whitelist the IP (see the second section at https://meta.wikimedia.org/wiki/Mass_account_creation). At your next event, as soon as possible, ideally one at least week beforehand, you can open a task on Phabricator for that (we need outgoing IPv4/IPv6).

However, immediately after that issue, it was not possible to make annonymous edits, nor edits from new accounts. I however could continue editing as have I done before. So it seems that there was a ban on new users.
The ban was visible in two ways. There was a little lock in the top right corner and there were also no "edit..." links available. The IP address of one of the machines was: 186.179.232.94

Did you try to edit other items?

the task we tried to complete was to add Surinamese labels (language srn or Sranan Tongo) to Wikidata on diseases. One example we tried to edit was the item on AIDS (https://www.wikidata.org/wiki/Q12199)

Urbanecm closed this task as Invalid.EditedApr 12 2017, 11:41 AM

Yeah, we were right. The first problem (account-creation) was caused by the six account limit (you may create 6 accounts max in 24 hours from one IP), the second problem (editing of Q12199) was caused by the semiprotection of the item by Wikidata sysops.

In future events you may solve the first problem by requesting IP lift cap here on Phabricator (see https://meta.wikimedia.org/wiki/Mass_account_creation). The request should be post at least one week in advance. The second problem may be solved by requesting confirmed status from Wikidata sysops or by editing another (non-protected) items.

As there is nothing to do from our side now and nothing we were able to do during the event I'm closing this as invalid.

Thanks for all the help and input. It has been a learning experience, which
will benefit future edit events.

Pigsonthewing added a subscriber: Pigsonthewing.EditedApr 12 2017, 2:24 PM

At your next event, as soon as possible, ideally one at least week beforehand, you can open a task on Phabricator for that (we need outgoing IPv4/IPv6).

The request should be post at least one week in advance.

Speaking as someone who regularly runs editathons and training events in third-party venues, what you suggest is often completely impractical.

Those of us who regularly undertake such outreach are awaiting the feature we requested, over two years ago, to solve this issue: T91928

No, wait. Over six years ago: T27000

Dereckson added a comment.EditedApr 12 2017, 7:32 PM

@Pigsonthewing Yes this will be an improvement, but you still will need to find someone with the correct rights access on wiki to add the rule.

Pending T27000 resolution, what you could do is to open a task explaining you'll get an event, but don't have the IP and can't get it before to be on site, and ask to someone with deployment access to be present before the event to push your config when you'll get the IP, so you ensure the request is expected and will be processed.