Page MenuHomePhabricator

OOjs UI v0.21 places the expand button on the wrong side
Closed, ResolvedPublic

Description

With the update of OOjs UI to v0.21 our expand button moves to the other side. This will go live next week if not fixed.

See attached screenshot from beta:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 12 2017, 1:25 PM
WMDE-Fisch triaged this task as High priority.Apr 12 2017, 1:26 PM
WMDE-Fisch moved this task from Proposed to Todo on the WMDE-QWERTY-Team board.

Another issue is that you have nested click targets which should always be avoided

Change 347874 had a related patch set uploaded (by Esanders):
[mediawiki/extensions/RevisionSlider@master] Fix alignment of expand icon

https://gerrit.wikimedia.org/r/347874

WMDE-Fisch moved this task from Todo to Done on the WMDE-QWERTY-Team board.Apr 12 2017, 9:15 PM

Change 347874 merged by jenkins-bot:
[mediawiki/extensions/RevisionSlider@master] Fix alignment of expand icon

https://gerrit.wikimedia.org/r/347874

@WMDE-Fisch Are you going to verify this and resolve that task when done?

Jdforrester-WMF closed this task as Resolved.Apr 17 2017, 8:03 PM
Jdforrester-WMF claimed this task.

@Volker_E I can confirm that the issue is fixed, thanks again.

Volker_E removed a subscriber: gerritbot.

Thanks to @Esanders for the patch and to you, @WMDE-Fisch for raising it quickly.

Tobi_WMDE_SW moved this task from Done to Demoed on the WMDE-QWERTY-Team board.Apr 25 2017, 3:08 PM