Page MenuHomePhabricator

[minor] frwiki - RC page with filters displays extra dot on a new line
Closed, ResolvedPublic

Description

(1) On frwiki (wmf.19) when 'New filters for edit review' beta feature is enabled, an extra dot on a newline is displayed on RC page.

When the beta feature is not enabled, the dot is not displayed:

(2) When RC page is reloading, the help link '?' will be displayed at the beginning of rcfilters-container. The same misplacement will occur when RC filters are not enabled, but the page reloads faster, so it's not noticeable.


Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 12 2017, 10:33 PM

The first problem comes from the "rclinks" message (french version: Afficher les $1 dernières modifications effectuées au cours des $2 derniers jours<br />$3.) with $3 being the list of show/hide links. When all of them are replaced in the new RC Filters UI, all that's left is a lonely period on a new line.

We could remove $3 from the message and append it as a different section when building the UI. In most languages, "rclinks" ends with <br />$3 or something similar so there would be little to no visual differences. Exceptions are:

languages/i18n/arz.json:	"rclinks": "بيين اخر $1 تعديل فى اخر $2 يوم، $3",
languages/i18n/avk.json:	"rclinks": "Nedira va $1 ironokaf betaks mali $2 ironokaf viel; $3 betamaks.",
languages/i18n/bqi.json:	"rclinks": "نشودادن آخرین $1 تغییر در $2 روز اخیر؛ $3",
languages/i18n/ksh.json:	"rclinks": "Zeisch de läzde {{int:pipe-separator}}$1{{int:pipe-separator}} Änderonge us de läzde {{int:pipe-separator}}$2{{int:pipe-separator}} Däch, un dun {{int:pipe-separator}} $3.",
languages/i18n/lrc.json:	"rclinks": "آخرین آلشتیا $1 نشو بیه د اخرین روزیا $2",
languages/i18n/luz.json:	"rclinks": "نیشۉ دائن ئاخأرین $1 تأغییر مئن $2 روٙز أخیر؛ $3",
languages/i18n/mzn.json:	"rclinks": "نـِشون هـِدائن  $1 پایانی دَچی‌‌یه‌ئون، $2 اِسـا روز ره دلـه؛"

Note that some of them do not display correctly here, possibly because of directionality charaters.

I have no idea if the proposed change would affect them in a problematic way.

So it looks like arz, bqi and luz do end in $3 (modulo RLE characters maybe)? And lrc and mzn don't have $3 at all, which seems like a bug. The only language where it would really make a difference is avk, and looking at that message I'm not sure if the translators understood what they were doing there. So your suggestion of removing $3 and adding the links separately sounds good to me.

Change 348825 had a related patch set uploaded (by Sbisson):
[mediawiki/core@master] Remove links list from the 'rclinks' message

https://gerrit.wikimedia.org/r/348825

About #2 (help link), it is caused by a global site script. Search for function rewritePageH1bis() in https://fr.wikipedia.org/wiki/MediaWiki:Common.js

About #2 (help link), it is caused by a global site script. Search for function rewritePageH1bis() in https://fr.wikipedia.org/wiki/MediaWiki:Common.js

I've left a message to the script maintainer.

Change 348825 merged by jenkins-bot:
[mediawiki/core@master] Remove links list from the 'rclinks' message

https://gerrit.wikimedia.org/r/348825

Etonkovidova updated the task description. (Show Details)Apr 20 2017, 8:38 PM

Since the mentioned lang wikis do not exist in betalabs, I will check it after deployment.

Etonkovidova added a comment.EditedMay 8 2017, 10:23 PM

Checked in wmf.21 for fr wiki and ksh, lrc, and mzn wikis (https://en.wikipedia.org/wiki/List_of_Wikipedias). No display problems are found.

QA Recommendation: Resolve

jmatazzoni closed this task as Resolved.May 9 2017, 6:56 PM