Page MenuHomePhabricator

OOjs UI v0.21 missing right border on RTL due to negative margin
Closed, ResolvedPublic

Description

Since the update to OOjs UI v0.21 theres a gap in the right border of the expandable bar of the RevisionSlider on RTL languages. This gap seems to be related to a negative margin applied see screenshot. Originally its a margin-left, but flipped due to RTL. When the negative margin is removed the border shows.

This will go live if not fixed till deployment next week.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 13 2017, 6:55 AM
WMDE-Fisch triaged this task as High priority.Apr 13 2017, 6:55 AM
WMDE-Fisch moved this task from Proposed to Todo on the WMDE-QWERTY-Team board.
Restricted Application added a project: UI-Standardization. · View Herald TranscriptApr 13 2017, 7:05 AM
Volker_E moved this task from Backlog to Doing on the OOUI board.

Change 348399 had a related patch set uploaded (by VolkerE):
[oojs/ui@master] MediaWiki theme: Fix border-color regression of frameless buttons

https://gerrit.wikimedia.org/r/348399

Volker_E moved this task from Doing to Reviewing on the OOUI board.Apr 16 2017, 8:40 PM

Change 348399 merged by jenkins-bot:
[oojs/ui@master] MediaWiki theme: Fix white border-color of frameless buttons

https://gerrit.wikimedia.org/r/348399

Jdforrester-WMF edited projects, added OOUI (OOjs-UI-0.21.1); removed OOUI.

@Jdforrester-WMF @Volker_E Thanks for addressing the issue!

Will the 0.21.1 version with that patch go into master before deployment today? Otherwise I would submit a temporary bugfix for the RevisionSlider so that the bug does not go live there.

@Jdforrester-WMF @Volker_E Thanks for addressing the issue!
Will the 0.21.1 version with that patch go into master before deployment today? Otherwise I would submit a temporary bugfix for the RevisionSlider so that the bug does not go live there.

There are no production deployments this week; I don't think we were going to do a 0.21.1 release this week, however, so a temporary bugfix for RevisionSlider would be needed for next week's deployment.

Ah yeah, thanks for the clarification. I will upload a temporary fix then. :-)

Change 348741 had a related patch set uploaded (by WMDE-Fisch):
[mediawiki/extensions/RevisionSlider@master] Temporary workaround for OOjs UI missing border bug

https://gerrit.wikimedia.org/r/348741

Change 348741 merged by jenkins-bot:
[mediawiki/extensions/RevisionSlider@master] Temporary workaround for OOjs UI missing border bug

https://gerrit.wikimedia.org/r/348741

Volker_E closed this task as Resolved.Apr 18 2017, 11:34 PM
Volker_E removed a project: Patch-For-Review.
Volker_E removed a subscriber: gerritbot.
Jdforrester-WMF renamed this task from OOjs UI v0.21 missing right border on RTL due to negativ margin to OOjs UI v0.21 missing right border on RTL due to negative margin.Apr 19 2017, 1:47 AM
WMDE-Fisch moved this task from Todo to Done on the WMDE-QWERTY-Team board.Apr 19 2017, 11:48 AM
Tobi_WMDE_SW moved this task from Done to Demoed on the WMDE-QWERTY-Team board.Apr 25 2017, 3:08 PM