Page MenuHomePhabricator

[regression] Dropdown Filter Panel is not anchored correctly to the search bar.
Closed, ResolvedPublic

Description

Seen on BetaLabs:

Compare to the current design in production:

Event Timeline

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptApr 13 2017, 4:28 PM

I do not see it in betalabs (enwiki, FF, Chrome). I see exactly the same output (partially visible in the first screenshot - 13 April 2017 (User creation log); 15:52 . . User account CrystalVansickle (talk | contribs) was created ‎), but the panel displayed normally. Please try again. I will look at it too, again.

This is an OOUI bug with PopupWidget positioning (according to Roan's debugging, the popup tries to adjust its positioning to the anchor even if the anchor is set as to not display)

Good news -- the new refactoring will "fix" this (as in, RCFilters won't use PopupWidget)

We should fix this in OOUI, too. Tagging @Catrope

Yes, there are bugs in the PopupWidget positioning code where it tries to adjust for the anchor position even when there is no anchor.

Change 344997 had a related patch set uploaded (by Mooeypoo):
[mediawiki/core@master] RCFilters: Adjust to use MenuTagMultiselectWidget

https://gerrit.wikimedia.org/r/344997

Change 344997 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Adjust to use MenuTagMultiselectWidget

https://gerrit.wikimedia.org/r/344997

Checked in betalabs and in wmf.4 - the issue is fixed.

Etonkovidova closed this task as Resolved.Oct 24 2017, 11:49 AM