Page MenuHomePhabricator

New translation panel shown when clicking on grey links needs layout adjustment
Closed, InvalidPublic

Description

Content Translation allows users to start a new translation when they are reading a Wikipedia article that is not available in their usual languages (shown as grey links). A panel is shown for the user to start the translation:

The grey area at the bottom part of the panel is intended to cover it from edge to edge. However, due to the way padding is applied, there is a white space surrounding the grey area. This was not the case before, so a regression may have resulted in the extra padding on the dialog.

Event Timeline

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptApr 14 2017, 3:43 PM
Amire80 moved this task from Needs Triage to Bugs on the ContentTranslation board.Jun 27 2017, 4:56 PM
wiki-helenatxu added a subscriber: wiki-helenatxu.

Hello! Can I get this bug assigned and resolve it?

Pginer-WMF closed this task as Invalid.EditedApr 28 2020, 1:19 PM

Hello! Can I get this bug assigned and resolve it?

Thanks for your interest in helping Content Translation. This particular issue seems that got solved as part of the work in T217827: Update grey interlanguage links entry point popup. So it is no longer a valid issue.

There is a pending fix on that same component listed in the remaining item of the checklist from T192316 that may be of your interest: text in the dialog should result to a computed size of 14px, but it is 12px currently because of the html element hierarchy.

If you are interested in more recent tickets, most of the focus of Content Translation will be in the area of supporting Section Translation (T243495). Please let us know if you are interested in any other particular area.

Hello Pau! Thanks for your message.

I'm new here and I would like to get familiar with the code in Content Translation and start helping with it. I will take a look a those tickets then, thank you! :)

Hello! Can I get this bug assigned and resolve it?

Thanks for your interest in helping Content Translation. This particular issue seems that got solved as part of the work in T217827: Update grey interlanguage links entry point popup. So it is no longer a valid issue.

There is a pending fix on that same component listed in the remaining item of the checklist from T192316 that may be of your interest: text in the dialog should result to a computed size of 14px, but it is 12px currently because of the html element hierarchy.

If you are interested in more recent tickets, most of the focus of Content Translation will be in the area of supporting Section Translation (T243495). Please let us know if you are interested in any other particular area.