Page MenuHomePhabricator

Create a preference for 'classic' ORES shading on RC Page
Closed, ResolvedPublic

Description

While the New Filters for Edit Review remains in beta, we will offer classic ORES shading on the RC Page as a preference. Here are the changes that need to happen:

  • Adapt the RC Page preference for controlling the "r" so that it turns on and off both the "r" and ORES shading.
    • New wording: Highlight likely problem edits with colors and an "r" for "needs review." (To set the level at which edits are marked, use the "Prediction Threshold" setting in the Watchlist preferences)
  • On ORES wikis to which we are newly releasing the beta, opt all existing ORES users into this option.
  • On ORES wikis that already have the beta, automatically opt in all users who currently have "r" turned on (which includes all migrated ORES beta users who haven't subsequently turned it off as well as anyone who turned on the shading option after the beta release). This, WITH ONE EXCEPTION...!
  • Users with the New Filters for Edit Review can not have this option. For anyone who has the New Filters or anyone who opts into it:
    1. Turn off the shading
    2. Turn off the "r"
    3. Remove the option from RC Page preferences preferences.
    4. But save the preference information and reinstate the preference if they turn off the New Filters beta. (If this last can't be easily done, it's not critical.)

Keeping the "r" and the shading together is consistent with how we do things on Watchlist. But it means that users will not be able to have the New Filters and the "r." These markers are functionally redundant with New Filters—the primary purpose of the "r" preference was to allow users to turn it off. So I don't imagine this will be a problem.

Details

Related Gerrit Patches:

Event Timeline

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptApr 14 2017, 8:18 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

This is the behavior @jmatazzoni asked for, I'll leave it to him to defend it.

Hi Amir. The idea is that as we roll out the New Filters interface to more pages (Watchlist is next), we will eliminate the "classic" ORES shading as an option on those pages. In other words, we are not planning to maintain both options indefinitely. We are replacing the old shading with the new filters.

I know that some people will have gotten used to the classic shading. But our plans are to 1) conform the ORES shading that still exists (e.g, on Watchlist) to the new threshold levels, and 2) provide the ability for users to set a default filter setting directly on the RC, etc. pages. In that environment, what would be the use case for maintaining the old shading?

Halfak added a subscriber: Halfak.Apr 20 2017, 2:18 PM

I don't think it's OK that we take away functionality from ORES users unless they opt in to new experimental software. We should allow current ORES users to use ORES highlighting at least until ERI is no longer a beta feature.

We're talking about the functionality for people who do not want to enable the ERI beta feature. In that environment, the ORES functionality should not substantially change.

I don't think it's OK that we take away functionality from ORES users unless they opt in to new experimental software. We should allow current ORES users to use ORES highlighting at least until ERI is no longer a beta feature.
We're talking about the functionality for people who do not want to enable the ERI beta feature. In that environment, the ORES functionality should not substantially change.

I see your point. But we made this decision together quite some time ago, and we've announced it to the ORES community a couple of times now. Let's see what happens. If we get push back, we can change course, as you say, at least until the New Filters are out of beta.

I don't remember making the decision to remove highlighting for people who would like to opt out of the new filter interface. Is there a substantial technical difficulty involved in allowing that functionality to remain?

jmatazzoni renamed this task from ORES highlights are completely disabled even when ERI is disabled to Create a preference for 'classic' ORES shading on RC Page.Apr 20 2017, 11:07 PM
jmatazzoni assigned this task to Catrope.
jmatazzoni updated the task description. (Show Details)

OK, @Ladsgroup and @Halfak, we'll add this back in while the beta is still a beta.Because we like you! See the rewritten Description for this task.

Roan says all this can be slipped in so that it will be part of the 5/24 release, which means that en.wiki will never miss the shading.

So now the post about all this to the ORES users is wrong. Or at least incomplete. I guess I can just go in and add the new info below the previous post?

Change 349354 had a related patch set uploaded (by Catrope):
[mediawiki/extensions/ORES@master] Make the preference for the "r" flag on the RC page also control highlighting

https://gerrit.wikimedia.org/r/349354

Change 349354 merged by jenkins-bot:
[mediawiki/extensions/ORES@master] Make the preference for the "r" flag on the RC page also control highlighting

https://gerrit.wikimedia.org/r/349354

Change 349537 had a related patch set uploaded (by Mattflaschen; owner: Catrope):
[mediawiki/extensions/ORES@wmf/1.29.0-wmf.20] Make the preference for the "r" flag on the RC page also control highlighting

https://gerrit.wikimedia.org/r/349537

Change 349537 merged by jenkins-bot:
[mediawiki/extensions/ORES@wmf/1.29.0-wmf.20] Make the preference for the "r" flag on the RC page also control highlighting

https://gerrit.wikimedia.org/r/349537

Etonkovidova added a comment.EditedApr 29 2017, 1:30 AM

Some issues that need to be sorted out (tested on enwiki betalabs):

(1) ORES wikis - beta feature "New filters for edit review" is OFF

  • Highlighting is brighter on RC and Watchlist comparing to Contribution page.
  • The option "Show only likely problem edits (and hide probably good edits)" (Preferences-Watchlist) will not apply to Contributions' "Hide probably good edits".

(2) ORES wikis - beta feature "New filters for edit review" is ON - tested on enwiki and ruwiki on betalabs:

  • 'r' is present in the Legend on RC page
  • Highlighting is brighter on RC and Watchlist comparing to Contribution page. Basically, with RC filters beta feature ON and the option Highlight likely problem edits with colors and an "r" for "needs review" on Preferences-Watchlist is enabled, a user see three different representation for the same edits (in the screenshots below keep an eye on the first edit - "Mavetuna2 (-1909)):

RC page with 'Very likely have problems' filter:

Watchlist displays the same edit with a bright highlighting

Contirbutions page - the pale highlighting

  • The option "Show only likely problem edits (and hide probably good edits)" is not applied to the settings on Watchlist ( Hide probably good edits) and Contributions page ('Hide probably good edits').

Note: The description for options "Highlight likely problem edits with colors and an "r"..." is very long in German. The option and description for ORES filter levels is also long.


bold textSome issues that need to be sorted out (tested on enwiki betalabs):
(1) ORES wikis - beta feature "New filters for edit review" is OFF

  • Highlighting is brighter on RC and Watchlist comparing to Contribution page.

That's odd, I'll try to find out why.

  • The option "Show only likely problem edits (and hide probably good edits)" (Preferences-Watchlist) will not apply to Contributions' "Hide probably good edits".

That's "expected behavior". The filters on the contributions page are not controllable by any preferences anywhere.

(2) ORES wikis - beta feature "New filters for edit review" is ON - tested on enwiki and ruwiki on betalabs:

  • 'r' is present in the Legend on RC page

I thought this would be hard, but I figured out a way. Working on a patch now.

  • Highlighting is brighter on RC and Watchlist comparing to Contribution page. Basically, with RC filters beta feature ON and the option Highlight likely problem edits with colors and an "r" for "needs review" on Preferences-Watchlist is enabled, a user see three different representation for the same edits (in the screenshots below keep an eye on the first edit - "Mavetuna2 (-1909)):

I'll look into this more.

  • The option "Show only likely problem edits (and hide probably good edits)" is not applied to the settings on Watchlist ( Hide probably good edits) and Contributions page ('Hide probably good edits').

Are you talking about the one on the RC tab or on the Watchlist tab? The one on the Watchlist tab should apply to the watchlist, and the one on the RC tab to the RC page (the latter is hidden if you have the beta feature enabled). Neither of them affects the contributions page, which is weird but "expected behavior" per my response above.

Note: The description for options "Highlight likely problem edits with colors and an "r"..." is very long in German. The option and description for ORES filter levels is also long.


Yeah, that's what happens when we write long English descriptions, they become even longer in German :/

(2) ORES wikis - beta feature "New filters for edit review" is ON - tested on enwiki and ruwiki on betalabs:

  • 'r' is present in the Legend on RC page

I thought this would be hard, but I figured out a way. Working on a patch now.

Nope, never mind, the legend is shared between RC and Watchlist so I can't remove the "r" from the RC legend without also removing it from the watchlist legend.

Change 351541 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/ORES@master] Fix highlighting on Special:Contributions

https://gerrit.wikimedia.org/r/351541

Change 351541 merged by jenkins-bot:
[mediawiki/extensions/ORES@master] Fix highlighting on Special:Contributions

https://gerrit.wikimedia.org/r/351541

All specs are in place along with fixes for Contributions highlighting intensity. The issue of not preserving Preferences-Watchlist "Show only likely problem edits (and hide probably good edits)" is in a separate issue: T164797: Watchlist 'Hide: probably good edits' box ignores selected Preferences-Watchlist option 'Show only likely problem edits...' after New filters beta feature is enabled

QA Recommendation: Resolve

jmatazzoni closed this task as Resolved.May 8 2017, 9:26 PM