Page MenuHomePhabricator

Linter extension indicating a "missing end" or/stripped tag when no such condition exists.
Closed, ResolvedPublic

Description

https://la.wikisource.org/w/index.php?title=Specialis:LintErrors/missing-end-tag&dir=prev

Is identifying https://la.wikisource.org/w/index.php?title=Pagina:The_poems_of_Gaius_Valerius_Catullus_-_Francis_Warre_Cornish.djvu/6&action=edit&lintid=5211 as having a missing end tag.

No such condition exists on checking ALL of the transculded templates.
https://la.wikisource.org/w/index.php?title=Formula:%3D&action=edit
https://la.wikisource.org/w/index.php?title=Formula:Center&action=edit
https://la.wikisource.org/w/index.php?title=Formula:Sc&action=edit
https://la.wikisource.org/w/index.php?title=Formula:Smaller&action=edit

I appreciate portions do have to be updated, but it would be appreciated if those implementing the changes would at the same time fix many of the long standing limitations and interactions I've mentioned here previously at the same time.

PLEASE fix the parser, Linter extension tool, Proofread Page, LST etc at the same time so I'm not wasting my time dealing with overly esoteric syntax interactions and I can get back to actually writing new content (and the templates to support it), rather than cleaning up potential breakages, that are only breakages because some of the developers thought it would be a good idea to make parts of Mediawiki conform more tightly, despite the fact that there were not broken as such.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 15 2017, 12:04 PM
ShakespeareFan00 renamed this task from Linter extension indicating a "missing end" stripped tag when no such condition exists. to Linter extension indicating a "missing end" or/stripped tag when no such condition exists..Apr 15 2017, 12:05 PM

Merged this as examining the code it's essentially the same whitespace handling issue.

ssastry closed this task as Resolved.Apr 16 2017, 1:59 PM
ssastry claimed this task.
ssastry added a subscriber: ssastry.

Absence of Linter guidance is because of T162920

But, the problem is here:

{{smaller|CAMBRIDGE UNIVERSITY PRESS WAREHOUSE,<br />AVE MARIA LANE.

{{smaller|''Glasgow'': 50, WELLINGTON STREET.}}

{{Smaller|''Leipzig'': F. A. BROCKHAUS.}} 

{{smaller|''New York'': THE MACMILLAN COMPANY.}} 

{{smaller|''Bombay and Calcutta'': MACMILLAN AND CO., {{sc|Ltd.}}}}
<br /><br /><br /><br /><br />
{{smaller|[''All Rights reserved'']}}}}

The first smaller is wrapping all the others and is closed at the end. The smaller template generates <span> tags. The empty lines between those span tags causes each of them to wrapped inside <p> tags. So, the first span tag is closed within the p-tag (and hence is missing the closing span tag). The closing <span> tag in the last smaller is now extra within the p-tag and gets removed.

But, all this feels a bit like too much arcana for editors to worry about. We'll have to think about how to selectively surface this information.

Closing as invalid, This isn't a bug as such but an issue with template documentation.