Page MenuHomePhabricator

[betalabs-regression] RC filters - in drop down filter panel there is no automatic scrolling to selected filter capsule
Closed, ResolvedPublic

Description

The issue is a little bit tricky to reproduce - for example, the default filters do not display the issue. Also, it seems that there are several small issues that look like regression.

Summary:

  • no clear indication (blue highlighting) when a capsule filter is clicked
  • no automatic scrolling in drop-down filter list when a capsule filter is clicked
  1. In betalabs on RC page select filters that are placed at some distance on the drop down filter list, e.g. 'Very likely good' and 'Page edits'
  2. Click on 'Very likely good' filter capsule - the drop down filter list will be displayed, automatically scrolled down to the selected filter. However, the capsule filter is not highlighted.

  1. Click on the another filter capsule - 'Page edits' - nothing happens: the dropdown is displayed but not scrolled down to 'Page edits' and there is no indication that the capsule filter was selected.

Previously, there was a clear indication when a capsule filter was selected, e.g. in plwiki - 'Very likely good' capsule filter was clicked, the drop-down list scrolls automatically to the selected filter and highlights it.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 17 2017, 7:43 PM

Okay, the reason this is happening now rather than before, is because now we are always focusing the widget on the input -- first, so we can immediately type in it, but also to support arrow behavior.
This means that when we choose a tag, the previous widget kept the focus on the tag (and you saw the blue outline) but the new widget moves the focus immediately to the input (and you don't see the focus styling.

I will attempt to fix this by synchronizing the selection behavior from the menu and tags.

Change 348651 had a related patch set uploaded (by Mooeypoo):
[mediawiki/core@master] RCFilters UI: Fix scrolling to item on tag click

https://gerrit.wikimedia.org/r/348651

The above fixes "no automatic scrolling in drop-down filter list when a capsule filter is clicked"

Still working on "no clear indication (blue highlighting) when a capsule filter is clicked"

Change 348652 had a related patch set uploaded (by Mooeypoo):
[mediawiki/core@master] RCFilters UI: Select tag when filter item is selected

https://gerrit.wikimedia.org/r/348652

The above fixes "no clear indication (blue highlighting) when a capsule filter is clicked" and returns the previously stated design.
Note that 'focus' of the tag looks different style still, seemingly by design?

Change 348651 merged by jenkins-bot:
[mediawiki/core@master] RCFilters UI: Fix scrolling to item on tag click

https://gerrit.wikimedia.org/r/348651

Change 348652 merged by jenkins-bot:
[mediawiki/core@master] RCFilters UI: Select tag when filter item is selected

https://gerrit.wikimedia.org/r/348652

jmatazzoni closed this task as Resolved.Apr 19 2017, 6:34 PM