Page MenuHomePhabricator

Impossible to preview page (or changes) in old wikitext editor using IE 6 when VisualEditor is enabled
Closed, ResolvedPublic8 Story Points

Description

It is impossible to preview page (or changes) in the built-in wikitext editor using IE 6 when VisualEditor is enabled. After clicking "Show preview" or "Show changes", some weird redirect happens where the POST-ed data are appended to the URL as GET data. This does not trigger a preview, and from the user's perspective all of their input is lost. Disabling VisualEditor in preferences (if you're a logged-in user) resolves the issue.

Event Timeline

matmarex created this task.Apr 18 2017, 5:33 PM
Restricted Application added a project: VisualEditor. · View Herald TranscriptApr 18 2017, 5:33 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

This is caused by rEVED188ec0f5d23c: Send users whose browsers support JS but are unsupported by MW to the WTE…. Looks like the addScript() added there should be inside the if()…

Jdforrester-WMF triaged this task as High priority.Apr 18 2017, 5:43 PM
Jdforrester-WMF set the point value for this task to 8.
Jdforrester-WMF moved this task from To Triage to TR0: Interrupt on the VisualEditor board.

Change 348781 had a related patch set uploaded (by Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] Fix logic for redirecting unsupported browsers to old editor

https://gerrit.wikimedia.org/r/348781

Change 348781 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Fix logic for redirecting unsupported browsers to old editor

https://gerrit.wikimedia.org/r/348781

Jdforrester-WMF closed this task as Resolved.Apr 19 2017, 10:02 PM
Jdforrester-WMF assigned this task to matmarex.
Jdforrester-WMF removed a project: Patch-For-Review.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptApr 19 2017, 10:02 PM