Page MenuHomePhabricator

User tester recruiting should no longer be running
Closed, ResolvedPublic

Description

Device context:

  • iOS 10.3.1
  • iPhone 6S
  • Wikipedia v5.4.1 beta 1

Steps to repro:

  • Perform a clean install of the app.
  • Complete the on-boarding screens.

Expected behavior:

  • Feed should load with todays content.

Actual behavior:

  • Feed loads with recruitment request to participate in design and user feedback studies.

This announcement was only supposed to run for a few days. Looks like we have client side issue with expiration not being respected, or a backend issue with not having an expiration as requested.

While we investigate/fix the app side issue can we remove the request from the announcement endpoint?

(PS. I didn't check if this is also still happening on Android).

Event Timeline

JMinor created this task.Apr 18 2017, 8:25 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 18 2017, 8:25 PM
JMinor triaged this task as Medium priority.Apr 18 2017, 8:25 PM

FWIW, I don't see it in the Android app.
The end time for iOS is set to Feb 14:
"end_time": "2017-02-14T00:00:00Z",

It's easy to remove this in MCS. The problem is that this week no deployments are allowed due to the datacenter switchover testing. I can deploy it on Monday, 4/24. But I guess that's not so bad, so the iOS app can be fixed to honor the end time in the meantime.

Change 348867 had a related patch set uploaded (by BearND):
[mediawiki/services/mobileapps@master] announcements: Remove recruitment surveys

https://gerrit.wikimedia.org/r/348867

Change 348867 merged by jenkins-bot:
[mediawiki/services/mobileapps@master] announcements: Remove recruitment surveys

https://gerrit.wikimedia.org/r/348867

JoeWalsh added a comment.EditedApr 20 2017, 11:35 AM

@JMinor @Fjalapeno it looks like there was logic in the app to keep announcements visible for new users (it wouldn't check & update the visibility unless the user had previously opened and closed the app) - can that be removed or was there another reason for having that logic?

deploy/2017-04-26/b5afcb89

It's deployed as of a couple of minutes ago. It may take a couple of hours for it to become visible to everybody due to caching.

bearND closed this task as Resolved.Jun 22 2017, 5:48 PM
bearND claimed this task.