Page MenuHomePhabricator

MediaWiki 1.28.0 Updater fails: Class 'FormatJson' not found
Closed, DeclinedPublic

Description

When running update.php on version 1.28 of media wiki the following error message occurs:

Your composer.lock file is up to date with current dependencies!
Going to run database updates for my_wiki
Depending on the size of your database this may take a while!
Abort with control-c in the next five seconds (skip this countdown with --quick) ... 0
PHP Fatal error: Class 'FormatJson' not found in /var/www/html/mediawiki/feedback/includes/exception/MWExceptionHandler.php on line 624

Event Timeline

Sorvis created this task.Apr 19 2017, 11:57 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 19 2017, 11:57 AM
Aklapper renamed this task from MediaWiki 1.28.0 Updater fails to MediaWiki 1.28.0 Updater fails: Class 'FormatJson' not found.Apr 19 2017, 1:37 PM

Hi @Sorvis, thanks for taking the time to report this!

How is this related to the Hitcounters extension?

I'm not sure what the issue is but another user reported the same error who uses HitCounter https://www.mediawiki.org/wiki/Extension_talk:HitCounters#Installing_on_1.28

When I disabled HitCounter then ran the Update.php it ran fine then as well. Its confusing what FormatJson has to do with that though.

tosfos added a subscriber: tosfos.Aug 11 2017, 10:21 PM

I believe this was fixed in dfc16883980d. Please re-test this by installing that version manually or trying the 1.29 or master branches.

Kghbln added a subscriber: Kghbln.Aug 11 2017, 10:46 PM
Aklapper changed the task status from Open to Stalled.Aug 22 2017, 11:16 AM

@Sorvis: Can you confirm @tosfos' comment?

Aklapper closed this task as Declined.Sep 14 2017, 8:59 PM

Unfortunately closing this report as @Sorvis did not provide further information.
@Sorvis: After you have provided the information asked for and if this still happens, please set the status of this report back to "Open" via the Add Action...Change Status dropdown. Thanks!