Page MenuHomePhabricator

[minor] RC filters - bullet points displayed blank if 'Highlight results' button is clicked
Closed, ResolvedPublic

Description

  1. On RC page with filters, click the 'Highlight button' but do not make any color selection or any other actions.
  2. Two things happen:
  3. the results set underneath the drop-down filter selection panel will contract a little bit which might give an impression that the result set is in some way affected by clicking 'Highlight results'
  4. the bullet points that are displayed blue will change to blank, empty circles

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 19 2017, 9:48 PM

Change 349102 had a related patch set uploaded (by Mooeypoo):
[mediawiki/core@master] RCFilters UI: Unify li bullets with and without highlights

https://gerrit.wikimedia.org/r/349102

The fix here fixes #3: https://gerrit.wikimedia.org/r/#/c/349102/

#4 is by design... The design specified that for highlighting, the "normal" bullets are white circles.
Pinging @Pginer-WMF for confirmation or change

This also seems to be the same way that the prototype behaves: http://pauginer.github.io/prototypes/edit-review/highlight-changes/index.html

The big difference is the lines "moving" between being "regular" bullets and white-circles, but the fix above corrects that (the *bullets* themselves still shift very very slightly, but the text and lines themselves are no longer moving with the above fix)

I moved this to 'needs review' and will continue up the chain (qa/etc) without fixing #4 unless there are objections...?

Change 349102 merged by jenkins-bot:
[mediawiki/core@master] RCFilters UI: Unify li bullets with and without highlights

https://gerrit.wikimedia.org/r/349102

#4 is by design... The design specified that for highlighting, the "normal" bullets are white circles.
Pinging @Pginer-WMF for confirmation or change

Yes, this is intentional. We didn't want the blue color of default bullet points to create confusion with those colors resulting from highlight.

Checked the fix - no "moving" is observed.

QA Recommendation: Resolve

jmatazzoni closed this task as Resolved.Apr 26 2017, 1:42 AM