Page MenuHomePhabricator

When viewing PDF files, `&page=0` results in "Error creating thumbnail: Invalid thumbnail parameters"
Closed, ResolvedPublic

Description

For example, https://meta.wikimedia.org/w/index.php?title=File:Report_for_offline_concepts_in_India_2017.pdf&page=0 results in a thumbnail error. This page is accessed by clicking "next page" and then "previous page" (as in, to return to the first page). Instead, this should probably default/redirect to the main file page and not to &page=0.

(I apologise but I am unable to locate a suitable tag for this task.)

Event Timeline

jrbs created this task.Apr 20 2017, 5:44 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 20 2017, 5:44 PM
Aklapper renamed this task from When viewing PDF files, `&page=0` results in thumbnail error to When viewing PDF files, `&page=0` results in "Error creating thumbnail: Invalid thumbnail parameters".Apr 20 2017, 8:24 PM

Change 381739 had a related patch set uploaded (by Rammanojpotla; owner: Rammanoj):
[mediawiki/core@master] Pdfhandler: Error creating thumbnail for &page=0

https://gerrit.wikimedia.org/r/381739

Cparle added a subscriber: Cparle.Nov 16 2017, 4:03 PM

@jrbs there's a patch in for this but it looks to me like it's been fixed already, I can't reproduce the bug on production

Cparle added a comment.Jan 9 2018, 5:37 PM

@jrbs ... just chasing this up

jrbs closed this task as Resolved.Jan 10 2018, 8:45 PM
jrbs claimed this task.

@jrbs ... just chasing this up

Looks fixed to me too! I'm not sure how Multimedia deals with "resolved" tickets, so if closing now is premature, please do reopen :)

Change 381739 abandoned by Aklapper:
Pdfhandler: Error creating thumbnail for &page=0

Reason:
As this is fixed already I am abandoning this patch. Thanks a lot Rammanojpotla for having worked on this, and sorry that your patch did not get merged. :-/

https://gerrit.wikimedia.org/r/381739