Page MenuHomePhabricator

[minor] RC filters - during reload conflicting filters "No changes during the given period match these criteria" is displayed
Closed, ResolvedPublic

Description

Note: The issue is really minor due to

  • the message "No changes during the given period match these criteria" is not visible with the filter drop-down panel is open. It's visible when a page is reloaded manually.
  • "No changes during the given period match these criteria" is generic enough to explain that there will be no results

Steps:

  1. Select conflicting filters - e.g. 'Unregistered' and 'Newcomers'
  2. When results (or rather the page with warning that there are no results) are loading, the message "No changes during the given period match these criteria" is displayed at the bottom of the page.

  1. When the page is fully loaded, the correct message "No results found because the search criteria are in conflict" will be displayed:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 21 2017, 7:31 PM
Etonkovidova renamed this task from [minor] RC filters - during reloading page for conflicting filter states "No changes during the given period match these criteria" is displayed to [minor] RC filters - during reload conflicting filters "No changes during the given period match these criteria" is displayed .Apr 21 2017, 7:33 PM

Change 356025 had a related patch set uploaded (by Mooeypoo; owner: Mooeypoo):
[mediawiki/core@master] RCFilters: Hide server-side 'empty results' message

https://gerrit.wikimedia.org/r/356025

Change 356025 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Hide server-side 'empty results' message

https://gerrit.wikimedia.org/r/356025

The issue is fixed - checked in betalabs.

QA Recommendation: Resolve

jmatazzoni closed this task as Resolved.May 31 2017, 11:11 PM