Page MenuHomePhabricator

Drag & Drop don`t show on 1.27.2
Closed, ResolvedPublic

Description

Hello Guys,
I got strange problem i install 1.27.2 version of MediaWiki and MsUpload not working for me anymore - i don`t see Drag & Drop :-(
This is my config:

$wgEnableWriteAPI = true; Enable the API
$wgEnableUploads = true;
Enable uploads
$wgFileExtensions = array('png','gif','jpg','jpeg','doc','xls','mpp','pdf','ppt','tiff','bmp','docx','xlsx','pptx','ps','odt','ods','odp','odg');
$wgAllowJavaUploads = true; Solves problem with Office 2007 and newer files (docx, xlsx, etc.)
$wgVerifyMimeType = false;
May solve problem with uploads of incorrect mime types
wfLoadExtension( 'MsUpload' );
$wgMSU_useDragDrop = true;
$wgMSU_showAutoCat = true;
$wgMSU_checkAutoCat = true;
$wgMSU_useMsLinks = false;
$wgMSU_confirmReplace = true; // Show the "Replace file?" checkbox
$wgMSU_imgParams = '400px';

I use Webbrowser Chrome 58 and Debian OS.
Maybe i need special PHP extansion to work this?
I enable info LogLevel in Apache but no errors :-(
Best Regards
TaKeN

Event Timeline

TaKeNeK created this task.Apr 24 2017, 8:23 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 24 2017, 8:23 AM
TaKeNeK updated the task description. (Show Details)Apr 24 2017, 8:27 AM

Edit: I just check and this is not webbrowser problem i check on Microsoft Edge and Microsoft Internet Explorer 11 ane same effect, no Drag & Drop box.

Best Regards
TaKeN

TaKeNeK added a comment.EditedApr 24 2017, 9:08 AM

More info about system:
Apache Server version: Apache/2.4.25

PHP 7.0.16-3 (cli) (built: Feb 22 2017 10:03:06) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies

with Zend OPcache v7.0.16-3, Copyright (c) 1999-2017, by Zend Technologies

Best Regards
TaKeN

Also unlikely, but are there any errors shown in the Developer Console tool of your web browser?

I just create a test server on my vmware and again check on fresh instalation ane same effect, please contact with me on e-mail i give you full access to this server include root to diagnose problem, but looks like problem with PHP7.

Best Regards
TaKeN

Are You there :)?

If and when some maintainer (see https://www.mediawiki.org/wiki/Extension:MsUpload ) looks at this task they might add comments...

SmartK added a subscriber: SmartK.Apr 26 2017, 2:58 PM

We are looking into it... thank you for the info...
Currently we use MW 1.28.1 and php7.0 ourself and so far with no problems.

Do You want access to my fresh version of 1.27.2 ?
I put for You guys on my vmware.

Sophivorus added a subscriber: Sophivorus.EditedApr 26 2017, 11:27 PM

@TaKeNeK Hi, I just installed a fresh MW 1.27.2 with the WikiEditor extension, the latest MsUpload and the exact same config settings you posted. I tested it on the latest Chrome, running PHP 7.1.2 on a Mac, and had no problems at all.

Can you leave a link to your wiki please?

Hello,
My test WIKI is on https://wiki.taken.pl - this is a fresh install with MsUpload.

Sophivorus added a comment.EditedApr 27 2017, 12:41 PM

Well, I checked your wiki and it looks like the problem is that you don't have the WikiEditor extension installed. WikiEditor is listed as a dependency of MsUpload, so it won't work without it. I created a task to add support when WikiEditor is disabled, but I don't know when that will actually happen, so I recommend you install WikiEditor in the meantime.

Please install WikiEditor and report back so that we may close this task if it works. Thanks!

i disable few days ago all extension because was thinking this is a problem with compatibility....

But now i know where was problem i don`t have this:

Enables use of WikiEditor by default but still allows users to disable it in preferences

$wgDefaultUserOptions['usebetatoolbar'] = 1;

Enables link and table wizards by default but still allows users to disable them in preferences

$wgDefaultUserOptions['usebetatoolbar-cgd'] = 1;

Displays the Preview and Changes tabs

$wgDefaultUserOptions['wikieditor-preview'] = 1;

Displays the Publish and Cancel buttons on the top right side

$wgDefaultUserOptions['wikieditor-publish'] = 1;

Without this option upload not working....
You can close - thanks for help

Sophivorus closed this task as Resolved.Apr 27 2017, 8:52 PM
Sophivorus claimed this task.

Glad we found the issue, bye!