Page MenuHomePhabricator

[wmf.21-regression] Posting a reply to Flow topics with multiple posts redirects users to no-js mode
Closed, ResolvedPublic

Description

In testwiki wmf.21 and betalabs.

  1. In betalabs on Flow board look for a topic that has more than one Reply
  2. On a Flow topic with multiple posts, click to 'Reply' on the first Reply link or on any but not the last. You will be redirected to the Permalink of that topic and there will be no VE option in the Reply area.

So, instead of being presented with this


a user is redirected to Permalink for this topic and Reply area won't have VE option ('Cancel' button is also not red). It looks like no-js mode behavior (almost, since 'Cancel' button is still present )

Details

Related Gerrit Patches:
mediawiki/extensions/Flow : wmf/1.29.0-wmf.21Follow-up c1beac48: fix JS error when clicking reply link
mediawiki/extensions/Flow : masterFollow-up c1beac48: fix JS error when clicking reply link

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptApr 24 2017, 10:07 PM
Etonkovidova renamed this task from [betalabs-regression] Posting a reply to Flow topics with multiple posts redirects users to no-js mode to [wmf.21-regression] Posting a reply to Flow topics with multiple posts redirects users to no-js mode.Apr 25 2017, 10:56 PM
Etonkovidova updated the task description. (Show Details)
Etonkovidova updated the task description. (Show Details)

Caused by a JS error: Cannot read property 'append' of undefined in mw.flow.ui.ReplyWidget.prototype.intializeEditor where it does this.$editorContainer.append(this.editor.$element); (this.$editorContainer is undefined)

Change 350331 had a related patch set uploaded (by Catrope):
[mediawiki/extensions/Flow@master] Follow-up c1beac48: fix JS error when clicking reply link

https://gerrit.wikimedia.org/r/350331

Change 350331 merged by jenkins-bot:
[mediawiki/extensions/Flow@master] Follow-up c1beac48: fix JS error when clicking reply link

https://gerrit.wikimedia.org/r/350331

Change 350334 had a related patch set uploaded (by Catrope):
[mediawiki/extensions/Flow@wmf/1.29.0-wmf.21] Follow-up c1beac48: fix JS error when clicking reply link

https://gerrit.wikimedia.org/r/350334

Change 350334 merged by jenkins-bot:
[mediawiki/extensions/Flow@wmf/1.29.0-wmf.21] Follow-up c1beac48: fix JS error when clicking reply link

https://gerrit.wikimedia.org/r/350334

Mentioned in SAL (#wikimedia-operations) [2017-04-26T00:20:47Z] <catrope@naos> Synchronized php-1.29.0-wmf.21/extensions/Flow/modules/flow/ui/widgets/mw.flow.ui.ReplyWidget.js: T163749 (duration: 01m 24s)

Etonkovidova added a comment.EditedApr 26 2017, 6:57 PM

Checked the fix in betalabs and testwiki (wmf.21).

QA Recommendation: Resolve

jmatazzoni closed this task as Resolved.May 3 2017, 4:59 PM
jmatazzoni claimed this task.