Page MenuHomePhabricator

SecurePoll requiring property_wiki for global elections
Open, HighPublic

Description

Right now when we try and create a global election the wiki property (used to assign what wiki an election will take place at) is hidden but still being required. Submitting a patch for now to remove the required part because of the timing nature.

Event Timeline

Restricted Application added subscribers: Jay8g, TerraCodes, Aklapper. · View Herald TranscriptApr 27 2017, 11:13 PM

Change 350779 had a related patch set uploaded (by Jalexander; owner: Jalexander):
[mediawiki/extensions/SecurePoll@master] Remove required from property_wiki

https://gerrit.wikimedia.org/r/350779

Change 350780 had a related patch set uploaded (by Jalexander; owner: Jalexander):
[mediawiki/extensions/SecurePoll@wmf/1.29.0-wmf.21] Remove required from property_wiki

https://gerrit.wikimedia.org/r/350780

Change 350779 merged by jenkins-bot:
[mediawiki/extensions/SecurePoll@master] Remove required from property_wiki

https://gerrit.wikimedia.org/r/350779

Change 350780 merged by jenkins-bot:
[mediawiki/extensions/SecurePoll@wmf/1.29.0-wmf.21] Remove required from property_wiki

https://gerrit.wikimedia.org/r/350780

Mentioned in SAL (#wikimedia-operations) [2017-04-27T23:36:01Z] <catrope@naos> Synchronized php-1.29.0-wmf.21/extensions/SecurePoll/includes/pages/CreatePage.php: Stop gap for fix global election creation (T164043) (duration: 00m 43s)

@Jalexander: Anything left to do here (all patches are merged) or can this UBN task be closed as resolved?

greg added a subscriber: greg.Jun 14 2017, 9:52 PM

@Jalexander: Anything left to do here (all patches are merged) or can this UBN task be closed as resolved?

ping?

greg lowered the priority of this task from Unbreak Now! to High.Jun 14 2017, 9:53 PM

/me assumes it's fixed, given the current election. But I'll leave open until James confirms.