Page MenuHomePhabricator

"Conflict of user rights changes! Please review and confirm your changes." in Special:Userrights
Closed, ResolvedPublic

Description

This is a result of lack of sorting in User::getGroups(). Encountered this myself in my dev wiki, not sure how to repro.

Details

Event Timeline

MaxSem created this task.May 1 2017, 6:06 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 1 2017, 6:06 PM

Change 350908 had a related patch set uploaded (by Krinkle; owner: MaxSem):
[mediawiki/core@master] Sort user groups

https://gerrit.wikimedia.org/r/350908

Change 350908 merged by jenkins-bot:
[mediawiki/core@master] user: Ensure returned user groups are sorted

https://gerrit.wikimedia.org/r/350908

Tgr added a subscriber: Tgr.Jan 7 2019, 1:26 AM

I'm getting this deterministically in Vagrant now; not sure if it's caused by the patch, not fixed by it or entirely unrelated. I'm guessing the last because as far as I can tell there isn't even any API request happening.

Tgr added a comment.Jan 7 2019, 1:27 AM

Reverting the patch fixes the issue though, so somehow related.

Change 482576 had a related patch set uploaded (by Gergő Tisza; owner: Gergő Tisza):
[mediawiki/core@master] Special:UserRights: Fix handling of empty conflict check value

https://gerrit.wikimedia.org/r/482576

I'm getting this on beta right now

While trying to promote to an admin

https://commons.wikimedia.beta.wmflabs.org/wiki/Special:UserRights/Fisch-WMDE

Change 482576 merged by jenkins-bot:
[mediawiki/core@master] Special:UserRights: Fix handling of empty conflict check value

https://gerrit.wikimedia.org/r/482576

Addshore closed this task as Resolved.Jan 7 2019, 12:30 PM
Addshore claimed this task.

Verified on beta

Restricted Application added a project: User-Addshore. · View Herald TranscriptJan 7 2019, 12:30 PM