Page MenuHomePhabricator

"Fatal exception of type "Wikimedia\Rdbms\DBQueryError" when url with Watchedlisted filters is used
Closed, ResolvedPublic1 Story Points

Details

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 2 2017, 10:32 PM
Etonkovidova updated the task description. (Show Details)May 2 2017, 10:42 PM
SELECT  rc_id,rc_timestamp,rc_user,rc_user_text,rc_namespace,rc_title,rc_comment,rc_minor,rc_bot,rc_new,rc_cur_id,rc_this_oldid,rc_last_oldid,rc_type,rc_source,rc_patrolled,rc_ip,rc_old_len,rc_new_len,rc_deleted,rc_logid,rc_log_type,rc_log_action,rc_params,(SELECT  GROUP_CONCAT(ct_tag SEPARATOR ',')  FROM `change_tag`    WHERE ct_rc_id=rc_id  ) AS `ts_tags`,fp_stable,fp_pending_since,ores_damaging_cls.oresc_probability AS `ores_damaging_score`,ores_goodfaith_cls.oresc_probability AS `ores_goodfaith_score`  FROM `recentchanges` LEFT JOIN `flaggedpages` ON ((fp_page_id = rc_cur_id)) LEFT JOIN `ores_model` `ores_damaging_mdl` ON (ores_damaging_mdl.oresm_is_current = '1' AND ores_damaging_mdl.oresm_name = 'damaging') LEFT JOIN `ores_classification` `ores_damaging_cls` ON ((ores_damaging_cls.oresc_model = ores_damaging_mdl.oresm_id) AND (rc_this_oldid = ores_damaging_cls.oresc_rev) AND ores_damaging_cls.oresc_class = '1') LEFT JOIN `ores_model` `ores_goodfaith_mdl` ON (ores_goodfaith_mdl.oresm_is_current = '1' AND ores_goodfaith_mdl.oresm_name = 'goodfaith') LEFT JOIN `ores_classification` `ores_goodfaith_cls` ON ((ores_goodfaith_cls.oresc_model = ores_goodfaith_mdl.oresm_id) AND (rc_this_oldid = ores_goodfaith_cls.oresc_rev) AND ores_goodfaith_cls.oresc_class = '1')   WHERE (rc_type != '0') AND (rc_type != '1') AND (rc_type != '6') AND (rc_source != 'wb') AND (wl_user IS NOT NULL) AND (rc_timestamp >= '20170425000000') AND (rc_type != 142) AND rc_new IN ('0','1')   ORDER BY rc_timestamp DESC LIMIT 50  
Function: SpecialRecentChanges::doMainQuery
Error: 1054 Unknown column 'wl_user' in 'where clause' (10.68.18.35)

It looks like the watchlist table isn't being joined in, most likely because you were logged out. We need to remove the watchlist filter group when the user is logged out.

Catrope claimed this task.May 2 2017, 11:34 PM
Catrope set the point value for this task to 1.

Change 351552 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/core@master] RCFilters: Only register watchlist filter group when user is logged in

https://gerrit.wikimedia.org/r/351552

Change 351552 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: Only register watchlist filter group when user is logged in

https://gerrit.wikimedia.org/r/351552

Checked in betalabs - the error is not displayed.

QA Recommendation: Resolve

jmatazzoni closed this task as Resolved.May 8 2017, 9:14 PM
Darwinius reopened this task as Open.Aug 17 2017, 3:39 PM
Darwinius added a subscriber: Darwinius.

Hello,

I keep getting this whenever I try to see my watchlist in Commons:

In the beginning, maybe a week ago, it only happened occasionally, but now it happens all the time.

Aklapper closed this task as Resolved.Aug 17 2017, 3:59 PM

@Darwinius: Please open a new task with steps to reproduce, as this is a new problem. (This task has been resolved since May.) Thanks!