Page MenuHomePhabricator

Page edits don't trigger notifications if an earlier page edit was minor
Closed, InvalidPublic

Description

First seen on the WMF internal office wiki, and then confirmed on mw.o. This is a pretty serious problem for me, because important changes were made to pages without my being made aware of them.

I am watching a page. Someone makes a minor edit to the page. It shows up in my watchlist, but (correctly) does not light up the toolbar, nor does it generate an email. Then the same person makes a non-minor edit to the same page. It correctly shows up in my watchlist, and incorrectly does not light up the toolbar (nor does it send email). Additional non-minor edits continue to not generate notifications.

I don't know if the behavior would be the same if 2 different people made edits, first minor then not.

Example edits can be seen here:
https://www.mediawiki.org/w/index.php?title=User:KSmith_(WMF)&diff=2460370&oldid=2415348
https://www.mediawiki.org/w/index.php?title=User:KSmith_(WMF)&diff=2460385&oldid=2460370

Event Timeline

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptMay 4 2017, 12:01 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
bd808 added a subscriber: bd808.May 4 2017, 12:05 AM

Further information:

A few minutes later, an edit with {{ping}} was made to a different page on mw.o within my user space. I got an email notification for that, but my toolbar still isn't showing any notifications.

The watchlist one is T29884: enotif doesn't send email if page on watchlist edited following a minor edit and enotif not configured to send minor edits.

Can you provide a diff for the {{ping}} edit (it should show in your Echo toolbar, unless it didn't follow all the mention requirements)?

I am watching a page. Someone makes a minor edit to the page. It shows up in my watchlist, but (correctly) does not light up the toolbar, nor does it generate an email. Then the same person makes a non-minor edit to the same page. It correctly shows up in my watchlist, and incorrectly does not light up the toolbar (nor does it send email). Additional non-minor edits continue to not generate notifications.

Note: There are 2 different systems, that are NOT interconnected, but are mixed up in this description:

  1. enotif - this is the ancient system, for getting emails about changes to pages you watchlist. It does not affect the toolbar, at all, ever. - The only user-configurable option is "Email me when a page or a file on my watchlist is changed" in e.g. https://www.mediawiki.org/wiki/Special:Preferences -- The main limitation, beyond the bug that Matt linked (and those linked therein), is that it will not send any further notifications until you've manually visited the page.
  2. notifications (aka echo) - this is the newer system, that has various features, configured at e.g. https://www.mediawiki.org/wiki/Special:Preferences#mw-prefsection-echo - It is this, that will show a yellow "you have new messages" in your toolbar, if-and-only-if someone edits your user talkpage (but not userpage - that feature request is T3876), amongst other unrelated features.

Can you provide a diff for the {{ping}} edit (it should show in your Echo toolbar, unless it didn't follow all the mention requirements)?

It did not follow the requirements (diff) - requirements. -- I've sent another ping, which will have worked.

I've sent another ping, which will have worked.

I did receive that ping, both in my notification bar and via email. I have lost track of what that confirms or refutes.

ksmith reopened this task as Open.May 4 2017, 3:47 PM

To be clear, this bug report is not just about email, nor is it about user pages.

There is a real (non-user) page which I am watching. If it gets a minor edit, and then a non-minor edit, my notification bar at the top does not light up. Regardless of whether or not I get email (I don't), that seems like a bug unrelated to T29884: enotif doesn't send email if page on watchlist edited following a minor edit and enotif not configured to send minor edits..

So I'm reopening this, at least until I understand what other phab task covers what it is reporting.

Catrope added a subscriber: Catrope.May 4 2017, 7:29 PM

There is a real (non-user) page which I am watching. If it gets a minor edit, and then a non-minor edit, my notification bar at the top does not light up.

The notification bar at the top never lights up in response to a page on your watchlist being edited, that's not a feature that exists or has ever existed. What it does do is light up if your user talk page was edited (regardless of whether it's on your watchlist), or if someone comments on a Flow topic that you watch or creates a new topic on a Flow page that you watch. (Given the latter, I can see where the confusion might have come from.)

Catrope closed this task as Invalid.May 4 2017, 7:30 PM

Ah. Thanks for the clarification, @Catrope . It never occurred to me that was the case. I guess even when I read claims to that effect, I wrongly assumed that my issue was being misunderstood, and not that I misunderstood how the feature works.

I really do hope that T29884 gets fixed, because the current behavior makes watching pages VERY unreliable.