Page MenuHomePhabricator

Problems with loading pages in en.wikisource Page: namespace due to broken gadgets
Closed, InvalidPublic

Description

These two posts detail the problem.
https://en.wikisource.org/wiki/Wikisource:Scriptorium#Problems_with_page_loading_in_the_Page:_namespace

This 2nd post link is mine (ineuw), and I pasted the output of the Firefox console. I hope these help.
https://en.wikisource.org/wiki/Wikisource:Scriptorium#Page_loading_for_editing_is_painstakingly_slow

  1. Opening the browser and loading the first page:

Gadget "CollapsibleNav" styles loaded twice. Migrate to type=general. See https://www.mediawiki.org/wiki/RL/MGU#Gadget_type. index.php:88:45
This page is using the deprecated ResourceLoader module "jquery.ui.widget". load.php:31:289
This page is using the deprecated ResourceLoader module "jquery.ui.core".
Please use "mediawiki.ui.button" or "oojs-ui" instead.

  1. Opening a second page while the first is still open:

Your skin is incompatible with VisualEditor. See https://www.mediawiki.org/wiki/VisualEditor/Skin_requirements for the requirements. load.php:122:233
Gadget "CollapsibleNav" styles loaded twice. Migrate to type=general. See https://www.mediawiki.org/wiki/RL/MGU#Gadget_type. 272:75:45
ReferenceError: KeyPress is not defined[Learn More] index.php:12:5

  1. Clicking on the Edit button:

Gadget "CollapsibleNav" styles loaded twice. Migrate to type=general. See https://www.mediawiki.org/wiki/RL/MGU#Gadget_type. index.php:130:45
This page is using the deprecated ResourceLoader module "jquery.ui.widget". load.php:31:289
This page is using the deprecated ResourceLoader module "jquery.ui.core".
Please use "mediawiki.ui.button" or "oojs-ui" instead. load.php:1:80
ReferenceError: KeyPress is not defined[Learn More] index.php:12:5

Event Timeline

Ineuw created this task.May 4 2017, 12:22 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 4 2017, 12:22 AM

this still seems that it is resolvable within enWS as it is most likely gadgets that need mw.util dependencies added

collapsiblenav gadget should be resolved

Ineuw added a comment.May 4 2017, 2:32 AM

These are the three warnings in the console when I tried to edit some pages without scripts of common.js and without gadgets.

This page is using the deprecated ResourceLoader module "jquery.ui.widget". load.php:31:289
This page is using the deprecated ResourceLoader module "jquery.ui.core".
Please use "mediawiki.ui.button" or "oojs-ui" instead.

warnings only, not the cause of failure.

If you have turned off gadgets and your local scripts, and there are no errors showing, it would seem reasonable to presume that the errors are sitting in your gadgets, or scripts.

You need to identify which gadget or script that you are using that is causing your issues.

Framawiki added a subscriber: Framawiki.
Ineuw added a comment.May 4 2017, 7:26 AM

Don't think its the gadgets because I cleared all gadget settings, cleared the common.js and common.css code and the page load began to function normally. Then began rebuilding my work environment with the gadgets and re-selected my preferences and this did not affect page load speed which remained normal good. I am now restoring snippets of code to locate the cause of the problem.

(Unrelated to Gadgets extension code hence removing tag.)

Aklapper renamed this task from Problems with loading pages in Wikisource Page: namesapce to Problems with loading pages in en.wikisource Page: namespace due to broken gadgets.May 4 2017, 8:34 AM
Aklapper added a comment.EditedMay 4 2017, 10:00 AM

Was this task reported to get help fixing those issues, or what is the intention? (Because on-wiki code is maintained by each community.)
For info how to fix problems, please see https://en.wikipedia.org/wiki/Wikipedia:Village_pump_(technical)#Old_script-pocalypse .
Note that https://en.wikisource.org/wiki/MediaWiki:Gadgets-definition might also need to express dependencies properly, see https://www.mediawiki.org/wiki/ResourceLoader/Developing_with_ResourceLoader#Client-side_.28dynamically.29

(Also, calling the undefined hookEvent in https://en.wikinews.org/wiki/MediaWiki:Gadget-dictionaryLookupHover.js needs to be fixed.)

I have fixed those calls for the gadgets that have been reported to cause errors.

Re dictionarylookup, it isn't our script and I have,idea how to fix.

Its usage here is

dictLookup	256 users with	6 active

so we may just be able to null it

I did see one script in Ineuw's common.js that needed to have dependency declared and have amended that.

Ineuw added a comment.May 4 2017, 10:19 AM

This was not a gadget problem. I'm still testing my work environment and will post the results here tomorrow.

Ineuw added a comment.May 5 2017, 8:07 AM

As requested by billinghurst, I disabled all gadgets and scripts in my userspace. Also, removed the contents of common.css, but I still get the following

This page is using the deprecated ResourceLoader module "jquery.ui.widget". load.php:31:289
This page is using the deprecated ResourceLoader module "jquery.ui.core".
Please use "mediawiki.ui.button" or "oojs-ui" instead.

I also received in one instance "Image corrupt or truncated. page168-1024px-Popular_Science_Monthly_Volume_66.djvu.jpg" but couldn't replicate it.

Those are warnings not errors. And before they become errors someone should fix them. "Image corrupt" is a different topic and unrelated here.

If I get it right this task is resolved?

Ineuw closed this task as Resolved.May 5 2017, 4:03 PM
Ineuw claimed this task.

In that case please close this ticket.

Billinghurst changed the task status from Resolved to Invalid.May 6 2017, 1:20 PM