Page MenuHomePhabricator

[wmf.21] RC filters - Monobook UI issues with highlights
Open, Needs TriagePublic1 Story Points

Description

Monobook, Safari 10:

Monobook Chrome:

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 5 2017, 12:17 AM
Etonkovidova renamed this task from Rc filters - Monobook UI issues with highlights to RC filters - Monobook UI issues with highlights .May 5 2017, 12:18 AM
Etonkovidova renamed this task from RC filters - Monobook UI issues with highlights to [wmf.21] RC filters - Monobook UI issues with highlights .May 5 2017, 12:46 AM
Catrope set the point value for this task to 1.
Catrope added a subscriber: Mooeypoo.
Wargo added a subscriber: Wargo.May 8 2017, 6:26 PM

Also checkboxes on the left side of names.

Change 352730 had a related patch set uploaded (by Catrope; owner: Catrope):
[oojs/ui@master] MenuSelectWidgets: Don't unconditionally hide all descendant inputs

https://gerrit.wikimedia.org/r/352730

Change 352735 had a related patch set uploaded (by Catrope; owner: Catrope):
[oojs/ui@master] OptionWidget: Use parent selector for icon/indicator/label styles

https://gerrit.wikimedia.org/r/352735

With my patches it looks a lot better:

There's still a discrepancy in the size of the highlight button when highlighting vs not, though:

Change 352730 merged by jenkins-bot:
[oojs/ui@master] MenuSelectWidgets: Don't unconditionally hide all descendant inputs

https://gerrit.wikimedia.org/r/352730

Change 352735 merged by jenkins-bot:
[oojs/ui@master] OptionWidget: Use parent selector for icon/indicator/label styles

https://gerrit.wikimedia.org/r/352735

This seems to be fixed, unless I'm missing something?

(There are other bugs related to the highlight menu + 'checkmark' issue in monobook, but they're dealt with in another task).

Is there anything still missing on this one that isn't covered by T165446: [betalabs-regression] monobook: cannot de-select a selected filter and T165444: [betalabs-regression] monobook: Highlight button displays checkmark ? or are we just waiting on OOUI release to move it to QA?

This seems to be fixed, unless I'm missing something?
(There are other bugs related to the highlight menu + 'checkmark' issue in monobook, but they're dealt with in another task).
Is there anything still missing on this one that isn't covered by T165446: [betalabs-regression] monobook: cannot de-select a selected filter and T165444: [betalabs-regression] monobook: Highlight button displays checkmark ? or are we just waiting on OOUI release to move it to QA?

I wrote:

There's still a discrepancy in the size of the highlight button when highlighting vs not, though:

Is that now fixed too?

As far as I can tell, not only is this not fixed, the checkmarks have become misaligned (possibly as a result of @Mooeypoo's patch to make them aligned in Vector?)