Deploy InternetArchiveBot on the Spanish Wikipedia (eswiki)
Closed, ResolvedPublic

Description

The Spanish Wikipedia has a large number of external links and is the 9th largest Wikipedia.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 7 2017, 8:03 PM
Cyberpower678 triaged this task as High priority.May 7 2017, 8:03 PM
Cyberpower678 changed the task status from Open to Stalled.Jul 28 2017, 11:43 PM

In order to move forward with deployment, the bot needs confirmed access just to edit the JS pages in its user space. Deployment has been stalled for this wiki until an admin confirms the bot.

Will ping the relevant people to add the bot temporary to the confirmed group for a month (eswiki requirements for getting autoconfirmed are more stringent than default). @Cyberpower678 I am right to asume User:InternetArchiveBot is the account we should flag?

InternetArchiveBot@eswiki now has confirmed permissions.

Cyberpower678 changed the task status from Stalled to Open.Jul 29 2017, 2:41 PM

Permissions have been granted.

I may have permission to actually edit my pages now, but I got stopped by an abuse filter.

SPAM - Spambots en páginas de usuario

I am constantly hitting some form of abuse filter. They seem to be tuned too strictly. In any event. I can't even post messages on talk pages without running into one. It's really hindering my progress.

Fine tuning has been finished. Bot is awaiting approval.

Cyberpower678 added a comment.EditedAug 6 2017, 11:58 PM

Bot approved. Pending deployment.

@MarcoAurelio I almost forgot. I need some translations done, before I can deploy the bot. Would you mind helping?

  • External links modified
  • Hello fellow editors,\n\nI have just modified {linksrescued} external links on [[{namespacepage}]]. Please take a moment to review [{diff} my edit]. If you have any questions, or need the bot to ignore the links, or the page altogether, please visit [[:m:InternetArchiveBot/FAQ|this simple FaQ]] for additional information. I made the following changes:\n{modifiedlinks}\nPlease refer to the FaQ for information on correcting errors with the bot.\n\nCheers.
  • External links found that need fixing
  • Hello fellow editors,\n\nI have found one or more external links on [[{namespacepage}]] that are in need of attention. Please take a moment to review the links I found and correct them on the article if necessary. I found the following problems:\n{modifiedlinks}\nWhen you have finished making the appropriate changes, please visit [[:m:InternetArchiveBot/FAQ|this simple FaQ]] for additional information to fix any issues with the URLs mentioned above.\n\nThis notice will only be made once for these URLs.\n\nCheers.
  • Trouble archiving links on the article
  • Hello. During the archive process, the archive returned errors for one or more sites that I submitted for archiving.\nBelow, I have included the links that returned with an error and the following error message.\n\n{problematiclinks}\nIn any event this will be the only notification in regards to these links, and no further attempt will be made to archive the links.\n\nCheers.
  • {link} is found to be dead. Recommend adding {newarchive} to the original URL.
  • {link} is found to be dead. No archive was found.
  • {link} is considered to be dead, however has been found to be alive. Recommend removing the dead flag from the URL.
  • Added archive {newarchive} to {link}
  • Replaced archive link {oldarchive} with {newarchive} on {link}
  • Corrected formatting/usage for {link}
  • Added {{tlx|dead link}} tag to {link}
  • Removed dead tag from {link}
  • Modified source for {link}
  • {problem} with error {error}
  • Rescuing {linksrescued} sources and tagging {linkstagged} as dead.
  • Notification of errors encountered when attempting to archive links
  • Notification of altered sources needing review
MarcoAurelio added a comment.EditedAug 7 2017, 9:51 AM

@MarcoAurelio I almost forgot. I need some translations done, before I can deploy the bot. Would you mind helping?

Sure thing.

  • External links modified

Enlaces externos modificados

  • Hello fellow editors,\n\nI have just modified {linksrescued} external links on [[{namespacepage}]]. Please take a moment to review [{diff} my edit]. If you have any questions, or need the bot to ignore the links, or the page altogether, please visit [[:m:InternetArchiveBot/FAQ|this simple FaQ]] for additional information. I made the following changes:\n{modifiedlinks}\nPlease refer to the FaQ for information on correcting errors with the bot.\n\nCheers.

Hola,\n\nAcabo de modificar el enlace externo {linkrescued} en [[{{namespacepage}}]]. Por favor tomáos un momento para revisar [{diff} mi edición]. Si tenéis alguna pregunta o necesitáis que el bot ignore los enlaces o toda la página en su conjunto, por favor visitad [[:m:InternetArchiveBot/FAQ|esta simple guía]] para ver información adicional. He realizado los siguientes cambios:\n{modifiedlinks}\nPor favor acudid a la guía anteriormente enlazada para más información sobre cómo corregir los errores que el bot pueda cometer.\n\nSaludos.

  • External links found that need fixing

Se encontraron enlaces externos que necesitan ser reparados

  • Hello fellow editors,\n\nI have found one or more external links on [[{namespacepage}]] that are in need of attention. Please take a moment to review the links I found and correct them on the article if necessary. I found the following problems:\n{modifiedlinks}\nWhen you have finished making the appropriate changes, please visit [[:m:InternetArchiveBot/FAQ|this simple FaQ]] for additional information to fix any issues with the URLs mentioned above.\n\nThis notice will only be made once for these URLs.\n\nCheers.

Hola,\n\nHe encontrado uno o varios enlaces externos en [[{{namespacepage}]] que necesitan de vuestra atención. Por favor tomáos un momento para revisar los enlaces que he econtrado y corregidlos en el artículo si es necesario. He encontrado los siguientes problemas:\n{modifiedlinks}\nCuando hayáis terminado de hacer los cambios apropiedos, por favor visitad [[:m:InternetArchiveBot/FAQ|esta página]] para ver información adicional sobre cómo arreglar los incidentes con los enlaces que he mencionado más arriba.\n\nEsta es la única notificación que se realizará para estos enlaces.\n\nSaludos.

  • Trouble archiving links on the article

Hubo un problema archivando los enlaces del artículo

  • Hello. During the archive process, the archive returned errors for one or more sites that I submitted for archiving.\nBelow, I have included the links that returned with an error and the following error message.\n\n{problematiclinks}\nIn any event this will be the only notification in regards to these links, and no further attempt will be made to archive the links.\n\nCheers.

Hola. Durante el proceso de archivado de enlaces, el archivo devolvió errores para uno o varios sitios que envié a archivar.\nMás abajo he incluido los enlaces que devolvieron errores y su correspondiente mensaje de error.\n\n{problematiclinks}\nEsta es la única notificación que se enviará en relación a dichos enlaces y no se realizarán más intentos para archivar esos enlaces.\n\nSaludos.

  • {link} is found to be dead. Recommend adding {newarchive} to the original URL.

El enlace {link} se encuentra caído. Se recomienda añadir {newarchive} a la dirección URL original.

  • {link} is found to be dead. No archive was found.

El enlace {link} se encuentra caído. No se ha encontrado ningún archivo.

  • {link} is considered to be dead, however has been found to be alive. Recommend removing the dead flag from the URL.

El enlace {link} se considera caído, sin embargo se encuentra disponible. Se recomienda retirar la plantilla de enlace caído de la URL.

  • Added archive {newarchive} to {link}

Se añadió el archivo {newarchive} a {link}

  • Replaced archive link {oldarchive} with {newarchive} on {link}

Se reemplazó el enlaze al archivo {oldarchive} con {newarchive} en {link}

  • Corrected formatting/usage for {link}

Se corrigió el formato o el uso para {link}

  • Added {{tlx|dead link}} tag to {link}

Se añadió la plantilla {{tlx|dead link}} a {link}

  • Removed dead tag from {link}

Se retiró la marca de enlace caído de {link}

  • Modified source for {link}

Se modificó la fuente para {link}

  • {problem} with error {error}

{problem} con error {error}

  • Rescuing {linksrescued} sources and tagging {linkstagged} as dead.

Rescatando referencia {linkrescued} y marcando {linkstagged} como caído.

  • Notification of errors encountered when attempting to archive links

Notificación sobre errores encontrados cuando se intentó archivar los enlaces

  • Notification of altered sources needing review

Notificación sobre referencias alteradas que necesitan revisión

I've done some (interface I think) translating as well in translatewiki.

Regards.

@MarcoAurelio I almost forgot. I need some translations done, before I can deploy the bot. Would you mind helping?

Sure thing.

  • External links modified

Enlaces externos modificados

  • Hello fellow editors,\n\nI have just modified {linksrescued} external links on [[{namespacepage}]]. Please take a moment to review [{diff} my edit]. If you have any questions, or need the bot to ignore the links, or the page altogether, please visit [[:m:InternetArchiveBot/FAQ|this simple FaQ]] for additional information. I made the following changes:\n{modifiedlinks}\nPlease refer to the FaQ for information on correcting errors with the bot.\n\nCheers.

Hola,\n\nAcabo de modificar el enlace externo {linkrescued} en [[{{namespacepage}}]]. Por favor tomáos un momento para revisar [{diff} mi edición]. Si tenéis alguna pregunta o necesitáis que el bot ignore los enlaces o toda la página en su conjunto, por favor visitad [[:m:InternetArchiveBot/FAQ|esta simple guía]] para ver información adicional. He realizado los siguientes cambios:\n{modifiedlinks}\nPor favor acudid a la guía anteriormente enlazada para más información sobre cómo corregir los errores que el bot pueda cometer.\n\nSaludos.

  • External links found that need fixing

Se encontraron enlaces externos que necesitan ser reparados

  • Hello fellow editors,\n\nI have found one or more external links on [[{namespacepage}]] that are in need of attention. Please take a moment to review the links I found and correct them on the article if necessary. I found the following problems:\n{modifiedlinks}\nWhen you have finished making the appropriate changes, please visit [[:m:InternetArchiveBot/FAQ|this simple FaQ]] for additional information to fix any issues with the URLs mentioned above.\n\nThis notice will only be made once for these URLs.\n\nCheers.

Hola,\n\nHe encontrado uno o varios enlaces externos en [[{{namespacepage}]] que necesitan de vuestra atención. Por favor tomáos un momento para revisar los enlaces que he econtrado y corregidlos en el artículo si es necesario. He encontrado los siguientes problemas:\n{modifiedlinks}\nCuando hayáis terminado de hacer los cambios apropiedos, por favor visitad [[:m:InternetArchiveBot/FAQ|esta página]] para ver información adicional sobre cómo arreglar los incidentes con los enlaces que he mencionado más arriba.\n\nEsta es la única notificación que se realizará para estos enlaces.\n\nSaludos.

  • Trouble archiving links on the article

Hubo un problema archivando los enlaces del artículo

  • Hello. During the archive process, the archive returned errors for one or more sites that I submitted for archiving.\nBelow, I have included the links that returned with an error and the following error message.\n\n{problematiclinks}\nIn any event this will be the only notification in regards to these links, and no further attempt will be made to archive the links.\n\nCheers.

Hola. Durante el proceso de archivado de enlaces, el archivo devolvió errores para uno o varios sitios que envié a archivar.\nMás abajo he incluido los enlaces que devolvieron errores y su correspondiente mensaje de error.\n\n{problematiclinks}\nEsta es la única notificación que se enviará en relación a dichos enlaces y no se realizarán más intentos para archivar esos enlaces.\n\nSaludos.

  • {link} is found to be dead. Recommend adding {newarchive} to the original URL.

El enlace {link} se encuentra caído. Se recomienda añadir {newarchive} a la dirección URL original.

  • {link} is found to be dead. No archive was found.

El enlace {link} se encuentra caído. No se ha encontrado ningún archivo.

  • {link} is considered to be dead, however has been found to be alive. Recommend removing the dead flag from the URL.

El enlace {link} se considera caído, sin embargo se encuentra disponible. Se recomienda retirar la plantilla de enlace caído de la URL.

  • Added archive {newarchive} to {link}

Se añadió el archivo {newarchive} a {link}

  • Replaced archive link {oldarchive} with {newarchive} on {link}

Se reemplazó el enlaze al archivo {oldarchive} con {newarchive} en {link}

  • Corrected formatting/usage for {link}

Se corrigió el formato o el uso para {link}

  • Added {{tlx|dead link}} tag to {link}

Se añadió la plantilla {{tlx|dead link}} a {link}

  • Removed dead tag from {link}

Se retiró la marca de enlace caído de {link}

  • Modified source for {link}

Se modificó la fuente para {link}

  • {problem} with error {error}

{problem} con error {error}

  • Rescuing {linksrescued} sources and tagging {linkstagged} as dead.

Rescatando referencia {linkrescued} y marcando {linkstagged} como caído.

  • Notification of errors encountered when attempting to archive links

Notificación sobre errores encontrados cuando se intentó archivar los enlaces

  • Notification of altered sources needing review

Notificación sobre referencias alteradas que necesitan revisión

I've done some (interface I think) translating as well in translatewiki.

Regards.

Thanks. I have installed the translations.

Bot is awaiting final deployment.

Hi. I see that I can now use the web interface to fix some pages one by one (thanks). It seems there (is|was) an error in the edit summaries: https://es.wikipedia.org/w/index.php?title=Antigua_Grecia&diff=prev&oldid=101289542

Also, the bot queue to do batch page analysis is disabled. Is that because it is not fully deployed yet?

Regards.

Cyberpower678 closed this task as Resolved.Sat, Sep 2, 8:31 PM

Deployed