Page MenuHomePhabricator

Fall back on Listed building in municipality category
Closed, ResolvedPublic

Description

When a specific commonscat does not exist for a listed building we should at least use the correct subcategory of Listed_buildings_in_Sweden_by_municipality.

For this we can use self.kommunName (all images with bbr also have a kommun).

  • Modifications to the default scheme of 'Category:Listed buildings in {kommunName} Municipality‎' will be needed for some municipalities.

Event Timeline

Municipalities for which the default does not work:
0184 Solna
2463 Åsele
0180 Stockholm
2510 Jokkmokk
2584 Kiruna
0117 Österåker
0115 Vallentuna
2521 Pajala
0382 Östhammar
2580 Luleå
0114 Upplands-Väsby
2581 Piteå
0139 Upplands-Bro
2480 Umeå
2462 Vilhelmina
2023 Malung
0319 Älvkarleby
2514 Kalix
0181 Södertälje
0331 Heby
0330 Knivsta
0980 Gotland
2421 Storuman
0160 Täby
1280 Malmö
0305 Håbo
0381 Enköping
0360 Tierp
2482 Skellefteå
2583 Haparanda
2518 Övertorneå

Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Aklapper reopened this task as Open.May 9 2017, 10:20 AM

Since the WLM bot should automatically be able to categorise any buildings with an "anläggning-id" if it is in the root category there is an argument for not categorising these by municipality.

Looking at the statistics we see however that spread of ids is:

  • 551 byggnads-id
  • 363 anläggnings-id
  • 13 miljö-id
  • 18 unknown (see T166507)
    • 15 linked to 1300000013542 (which should likely be 21300000013542 a byggnads-id)
    • 3 linked to 21000000981008 which seems to not have a corresponding entry

Thus falling back on municipality categories is still motivated.


Id's which were not automatically resolved by type were:

Byggnad

21000001442967
21000001007732
21000001008222
21000001442880
21000001742822
21000001442940
21000001007736
21000001008226
21000001007734
21000001008220
21000000969280
21000001008320
21000000969282
21000001008228
21000001007726
21000001007702
21000001602780
21000000983060
21000001008282
21000001442963
21000001007700
21000001007728
21000000980922
21000001005987
21000001007708
21000001007724
21000001442960
21000000970026
21000000977540
21000000970020
21000001442900
21000001008230
21000001742844

Anläggning

21000001678061
21000001442760
21000001742801

Lokal_Profil moved this task from Review to Done on the User-LokalProfil board.May 30 2017, 9:08 AM