Cursor jumps when working at bottom of the article?
Open, Needs TriagePublic

Description

Per Kerry Raymond at en.wiki, in early April (it still occurs):

Description When working at the bottom of an article, clicking on items in the tool bar shifts the displayed article to the top of the article instead of leaving it at the bottom. It has happened on several articles (at first I just thought I'd click something by accident, but after a while doing everything with great care, it became clear it was not my error).
Intention: I am adding commons categories to a bunch of articles.
Steps to Reproduce: This should involve the following sequence of actions in the VE, scrolling to the bottom of the article text, clicking curson, adding text "External links", clicking Toolbar to select Heading format, hit Return (so cursor is under the new heading), click on Toolbar Insert > Template > fill it out > Insert, then Save.
Results: In both clicking of the Toolbar (for Paragraph format and Insert Template) the displayed article did not remain at the end of the article where I was working, but jumped to top of the article. The article I was specifically working on most recently where this occured was Selhurst, North Ward and this is the diff. Feel free to roll back and repeat my actions. Now I add a lot of commons categories to articles and I don't think this problem was occurring in the past (it's quite maddening so I am unlikely to have failed to notice). It seems a recent change in behaviour. Note, although the display of the article is in the wrong position, the VE is not forgetting the location of the cursor. The actions of changing the paragraph format and inserting the template are still occuring at the bottom of article (you just can't see them). So the outcome is correct, but the experience is not very "visual" as you have to keep scrolling back down to the bottom of the article to check that what you expected to happen actually happened. Kerry (talk) 07:52, 2 April 2017 (UTC)
Expectations: bottom of the article would remain displayed

Web browser Chrome 57.0.2987.133 (latest)
Operating system Windows 8.1
Skin default

TheDJ said "Was able to confirm this behavior after inserting the "citation needed" template at the bottom of an article."

I can't reproduce with Chrome Version 58.0.3029.96 (64-bit)/Win 10.

Elitre created this task.May 8 2017, 9:22 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 8 2017, 9:22 AM
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Aklapper reopened this task as Open.May 9 2017, 10:21 AM
Elitre added a subscriber: Deskana.Jul 7 2017, 8:23 AM

Kerry says it's still happening.