Page MenuHomePhabricator

Diff on medium sized table takes a very long time then shows no diff
Closed, ResolvedPublic1 Story Points

Description

Edit a few cells in a ~200 cells table. The visual diff takes a few seconds to load and shows no changes.

Event Timeline

Esanders created this task.May 8 2017, 10:08 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 8 2017, 10:08 AM

The lack of diff is cause by the timeout code - although it should result in the entire table being replaced. Also the timeout happens too high up to catch the slow tree diff.

Change 352642 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/VisualEditor@master] Generate visual diff only after switching to visual diff tab

https://gerrit.wikimedia.org/r/352642

Change 352669 had a related patch set uploaded (by Esanders; owner: Esanders):
[VisualEditor/VisualEditor@master] Upgrade tree differ to support timeouts, and handle them

https://gerrit.wikimedia.org/r/352669

Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Aklapper reopened this task as Open.May 9 2017, 10:19 AM

Change 352642 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Generate visual diff only after switching to visual diff tab

https://gerrit.wikimedia.org/r/352642

Change 352669 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] Upgrade tree differ to support timeouts, and handle them

https://gerrit.wikimedia.org/r/352669

Jdforrester-WMF closed this task as Resolved.May 10 2017, 5:47 PM
Jdforrester-WMF assigned this task to Esanders.
Jdforrester-WMF triaged this task as Normal priority.
Jdforrester-WMF moved this task from To Triage to TR6: Visual diffs on the VisualEditor board.
Jdforrester-WMF set the point value for this task to 1.
Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMay 10 2017, 5:47 PM

Change 353367 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (347765f82)

https://gerrit.wikimedia.org/r/353367

Change 353367 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (347765f82)

https://gerrit.wikimedia.org/r/353367