NullRevisionCreator.php: Failed to create null revision
Closed, ResolvedPublic

Description

Happening on master:

[f4931fa272c7c5184ccbfd44] /wiki/index.php/Special:ImportFile RuntimeException from line 44 of /var/www/html/wiki/extensions/FileImporter/src/Services/NullRevisionCreator.php: Failed to create null revision

Backtrace:

#0 /var/www/html/wiki/extensions/FileImporter/src/Services/Importer.php(210): FileImporter\Services\NullRevisionCreator->createForLinkTarget(integer, User, string, boolean)
#1 /var/www/html/wiki/extensions/FileImporter/src/Services/Importer.php(109): FileImporter\Services\Importer->createPostImportNullRevision(FileImporter\Data\ImportDetails, User)
#2 /var/www/html/wiki/extensions/FileImporter/src/SpecialImportFile.php(297): FileImporter\Services\Importer->import(User, FileImporter\Data\ImportDetails)
#3 /var/www/html/wiki/extensions/FileImporter/src/SpecialImportFile.php(233): FileImporter\SpecialImportFile->doImport(FileImporter\Data\ImportDetails)
#4 /var/www/html/wiki/extensions/FileImporter/src/SpecialImportFile.php(152): FileImporter\SpecialImportFile->actuallyExecutePost(FileImporter\Data\ImportDetails)
#5 /var/www/html/wiki/includes/specialpage/SpecialPage.php(522): FileImporter\SpecialImportFile->execute(NULL)
#6 /var/www/html/wiki/includes/specialpage/SpecialPageFactory.php(578): SpecialPage->run(NULL)
#7 /var/www/html/wiki/includes/MediaWiki.php(287): SpecialPageFactory::executePath(Title, RequestContext)
#8 /var/www/html/wiki/includes/MediaWiki.php(862): MediaWiki->performRequest()
#9 /var/www/html/wiki/includes/MediaWiki.php(523): MediaWiki->main()
#10 /var/www/html/wiki/index.php(43): MediaWiki->run()
#11 {main}
Addshore created this task.May 8 2017, 11:25 AM
Restricted Application added a project: User-Addshore. · View Herald TranscriptMay 8 2017, 11:25 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Addshore moved this task from Proposed to Sprint ready on the WMDE-QWERTY-Team-Board board.
Addshore moved this task from Backlog to In Progress on the User-Addshore board.

Change 352571 had a related patch set uploaded (by Addshore; owner: Addshore):
[mediawiki/extensions/FileImporter@master] Use GAID_FOR_UPDATE for getArticleID for NullRevisionCreator

https://gerrit.wikimedia.org/r/352571

Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Aklapper reopened this task as Open.May 9 2017, 10:19 AM

Change 352571 merged by jenkins-bot:
[mediawiki/extensions/FileImporter@master] Use GAID_FOR_UPDATE for getArticleID for NullRevisionCreator

https://gerrit.wikimedia.org/r/352571

Restricted Application added a project: TCB-Team. · View Herald TranscriptJun 13 2017, 8:10 AM
Tobi_WMDE_SW closed this task as Resolved.