Page MenuHomePhabricator

Automatically add Volunteer badge to users on Phabricator
Closed, DeclinedPublic

Description

The Volunteer badge that was created on phabricator should be automatically added to users that have committed atleast 1-2 code changes to a repo, or have resolved 1-2 tasks that were assigned to them.

However, if anyone else has any other ideas on criteria for the badge assignment please mention them here.

(Badge in question, https://phabricator.wikimedia.org/badges/view/3/ )

Thanks,
Zppix

Event Timeline

Zppix created this task.May 8 2017, 12:42 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 8 2017, 12:42 PM
Zppix updated the task description. (Show Details)May 8 2017, 12:43 PM
Aklapper renamed this task from Volunteer Badge assignment on Phabricator to Automatically add Volunteer badge to users on Phabricator.May 8 2017, 5:30 PM
Aklapper triaged this task as Lowest priority.

Unlikely to happen as there is no such code to achieve this.

Zppix added a comment.May 8 2017, 7:13 PM

@Aklapper Herald cannot do this?

Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Aklapper reopened this task as Open.May 9 2017, 10:19 AM

That badge describes the vast majority of accounts here, plus staff (WMF/affiliate/etc) when they contribute in their volunteer time. Recommend decline.

greg added a subscriber: greg.May 9 2017, 6:49 PM

+1 to @Quiddity's comment.

Aklapper closed this task as Declined.May 9 2017, 7:00 PM
Zppix added a comment.May 9 2017, 7:05 PM

That badge describes the vast majority of accounts here, plus staff (WMF/affiliate/etc) when they contribute in their volunteer time. Recommend decline.

But currently, very few users have the badge... so "vast majority" does not equal current number of users with badge

It creates no issue that very few users have the badge, and user are free to get the badge if they want. So that's not an argument for a Herald rule...

Zppix added a comment.May 9 2017, 7:12 PM

Yes, but how will anyone know that theres currently nothing documenting how badges are assigned, or how to request them, etc

demon added a subscriber: demon.May 9 2017, 7:15 PM

I think staff/volunteer badges are a bad idea. We're all equals here :)

Zppix added a comment.May 9 2017, 7:17 PM

I think staff/volunteer badges are a bad idea. We're all equals here :)

I disagree, specifying whom is staff and whom is volunteer makes it easier for people who don't quite know who is who, to contact the right person, or when requesting something they could find out if who they are wanting to contact would even possibly have that access, etc etc.

demon added a comment.May 9 2017, 7:20 PM

Ok, you've made an argument for a staff badge (which I still don't agree with), but what about volunteer? Isn't it pretty obvious that everyone's a volunteer if they're not a staff member?

Tbh, I just think the whole idea of badges is pretty dumb and leads to hat collecting.

Yes, but how will anyone know that theres currently nothing documenting how badges are assigned, or how to request them, etc

By creating documentation. Or curious people might click on existing badges.
Not by automatically assigning "because we can". I don't assign random people to review patches so they know that patch review exists either. ;)

I disagree, specifying whom is staff and whom is volunteer makes it easier for people who don't quite know who is who

No, because that implies that it's (for reasons we do not know, as you have not explained the underlying problem you want to solve but offer what you think is a solution) relevant to know who is staff and who is not. You could find out who a person is by clicking the name of the person.

Zppix added a comment.May 9 2017, 7:29 PM

Yes, but how will anyone know that theres currently nothing documenting how badges are assigned, or how to request them, etc

By creating documentation. Or curious people might click on existing badges.
Not by automatically assigning "because we can". I don't assign random people to review patches so they know that patch review exists either. ;)

Shouldn't the documentation been created or atleast drafted when the badges were created, and what do you mean by curious people clicking on them, all that does is show the badge icon, badge name, and edit history.

I disagree, specifying whom is staff and whom is volunteer makes it easier for people who don't quite know who is who

No, because that implies that it's (for reasons we do not know, as you have not explained the underlying problem you want to solve but offer what you think is a solution) relevant to know who is staff and who is not. You could find out who a person is by clicking the name of the person.

The problem is that we can't expect everyone to know who staff are, and it would be a way to easily identify whom is staff on phabriactor, having WMF in the username (if thats even the case as not all staff have that) isnt a very reliable way to do it in Phabricator (anyone can put WMF in their name).

demon added a comment.May 9 2017, 7:32 PM

Why does anyone need to know who is staff and who isn't? In what way is that relevant to technical discussions? We discuss things based on merit, not who is making a comment.

Zppix added a comment.May 9 2017, 7:35 PM

Why does anyone need to know who is staff and who isn't? In what way is that relevant to technical discussions? We discuss things based on merit, not who is making a comment.

For example, lets say I need to coordinate with a staff member, but I don't know who staff are, so I look at phabricator to look to see who I would contact (yes i know wiki pages exist but instead of searching the wiki pages just looking in one place would be easier no?)

Aklapper removed a subscriber: Aklapper.May 9 2017, 7:36 PM

As long as the underlying problem is not explained (for this specific task that means: the problem which leads you to think that it's relevant if someone pays somebody or not), this conversation does not feel like making much progress, hence I'm unsubscribing from this task.

demon added a comment.May 9 2017, 7:37 PM

Why does anyone need to know who is staff and who isn't? In what way is that relevant to technical discussions? We discuss things based on merit, not who is making a comment.

For example, lets say I need to coordinate with a staff member, but I don't know who staff are, so I look at phabricator to look to see who I would contact (yes i know wiki pages exist but instead of searching the wiki pages just looking in one place would be easier no?)

That doesn't make sense. I imagine you're needing to coordinate with someone on a specific project/task which this badge wouldn't show. "Coordinate with (a random) staff member" isn't an actual workflow.

greg added a comment.May 9 2017, 7:38 PM

@Zppix you aren't making a (good) case yet. A hypothetical of "needing to coordinate with a staff member" doesn't make sense. Why? About what? Once you answer those real-world aspects to this hypothetical then it becomes clear who (or what team) you should be speaking with. This badge does not help you in any way. Would you ping everyone who has that badge? No. Thinking is required for interacting with people (and organizations).

demon added a comment.May 9 2017, 7:38 PM

Also: there isn't a staff badge yet (thankfully). So this whole discussion is rather pointless.

Zppix added a comment.May 9 2017, 7:41 PM

@greg Let me try explaining my POV this way, let's say I'm looking at a project page and I'm trying to find a member of staff thats associated with the project, let's say for a deployment outside of a normal window (for example an urgent fix to a breaking change), instead of looking through many members of a project you could easily ID an staff member.

demon added a comment.May 9 2017, 7:42 PM

But not all staff members have deploy rights. And a lot of non-staff members also have deploy rights. So that's not super useful either.

greg added a comment.EditedMay 9 2017, 7:43 PM

let's say I'm looking at a project page and I'm trying to find a member of staff thats associated with the project, let's say for a deployment outside of a normal window (for example an urgent fix to a breaking change)

All your answers are on https://wikitech.wikimedia.org/wiki/Deployments then.

Restricted Application added a project: User-Zppix. · View Herald TranscriptJul 11 2018, 11:21 AM