Page MenuHomePhabricator

Handle 5xx errors from FE application in nginx
Open, Needs TriagePublic

Description

As a user
I want to see a user-friendly error message
so that I am aware of technical problems when opening spenden.wikimedia.de

AC

  • nginx shows a beautiful bilingual error page when upstream server (fpm) fails to respond (timeout)

Background

  • existing "maintenance mode" page (spenden.wikimedia.de:/usr/share/nginx/www/spenden.wikimedia.de/maintenance_mode/web) could be partially reused

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.