Page MenuHomePhabricator

Check wordings with users to improve messages before releasing them to translation
Closed, ResolvedPublic

Description

We try to phrase the messages in the best way possible, however, we should check them by testing and/or exposing them to people.
There are two tracks we can pursue in parallel:

Needed preparation in each case: Communicating, explaining our idea of review and the constraint gadget.

Typical usability test:
We meet with users in real life or in a hangout, show the messages in context and ask them what they think is wrong and what they should do.
Needed Preparation: Prepare messages and context (screenshots) and list of basic questions

On Wiki feedback
We show the current messages on-wiki and ask for feedback. In order to show who needs to understand the messages, we could frame it via two scenarios, of a less experienced user and an experienced editor, so volunteer reviewers of the texts are aware that both need to understand the text. We should ask for people who do not know the constraint service by heart already.
Needed Preperation: Scenarios

@Lea_Lacroix_WMDE : is that something we can prepare?

Related Objects

View Standalone Graph
This task is connected to more than 200 other tasks. Only direct parents and subtasks are shown here. Use View Standalone Graph to show more of the graph.

Event Timeline

Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Lydia_Pintscher moved this task from incoming to consider for next sprint on the Wikidata board.

The improved constraint messages have been done (and translated) for a while – there was some feedback on Project Chat, and some of that was incorporated into improvements to the message, but overall the new messages seem to have been accepted by the community.