Page MenuHomePhabricator

Inventory APIs needed for an API driven mobile website
Closed, ResolvedPublic

Description

If we are to build the mobile website as an API driven frontend, we need to inventory which APIs we would use, and identify which ones already exist and which ones would need to be created.

AC

  • Publish a list of which APIs exist and which need to be created on-wiki
  • Create follow up tasks for APIs which do not yet exist or need changes and to discuss with services

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMay 8 2017, 4:22 PM

@ovasileva @Jdlrobson I'm not sure how we tag tasks related to the project, do we have a tag for it?

We can create one... and then have the epic here and pull in as needed. I did that with Trending-Service
T101046 and T145219 are also very similar and outdated.. so we should probably consolidate these epics with this card.

Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Qse24h closed this task as a duplicate of T164723: New git repository: <repo name>.
Aklapper reopened this task as Open.May 9 2017, 10:19 AM
ovasileva triaged this task as Medium priority.May 9 2017, 3:10 PM
ovasileva updated the task description. (Show Details)
ovasileva updated the task description. (Show Details)
Jhernandez updated the task description. (Show Details)May 9 2017, 3:11 PM

Weekipedia uses RESTBase APIs directly and adds new ones wher they are not missing https://github.com/jdlrobson/weekipedia/tree/master/libs/server/endpoints

This would add all the APIs MobileFrontend would need.
I was very thorough so surely it's just a case of me writing these down on a wiki somewhere?

Thanks a lot @Jdlrobson 👏 . Great work

cc/ @Fjalapeno, I remember we talked about this in January or March, Jon has summarized the needed APIs for the api driven web frontend. Have a look, it is an interesting read to see services we're going to need & to evaluate if we need them as REST and if they can be shared with apps.

Peter added a subscriber: Peter.Jul 3 2017, 5:54 PM

The one thing that strikes me as useful would be an edit-feed service which allows us to generate page history/recent changes/watchlist .

We have a lot of code debt in MobileFrontend relating to this feature and I wouldn't want to repeat this

I see the services team have some goals that overlap with us on T115876... worth exploring?

@Jhernandez thanks! Just to document, we have a meeting to cover this work.

@Jdlrobson the edit history is an interesting - I'll document that as well